CVE-2025-14881
Insecure direct object reference
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
3.8
Insecure direct object reference
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
- Record
CVE-2025-14881- CVSS 4.0
- 3.8 Low
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U - Weakness
- CWE-639
- Updated
- 2026-11-02
EUVDEUVD-2025-204530
3.8
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
- Record
EUVD-2025-204530- CVSS 4.0
- 3.8 Low
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-r2h2-g46h-8mx8
3.8
pretix has Broken Access Control Allowing Cross-User File Access via UUID
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
- Record
GHSA-r2h2-g46h-8mx8- CVSS 4.0
- 3.8 Low
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U - Weakness
- CWE-639
- Updated
- 2026-11-02
NVD
3.8
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
- Record
CVE-2025-14881- CVSS 4.0
- 3.8 Low
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-639
- Updated
- 2026-11-02
OSV
3.8
Insecure direct object reference
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
- Record
CVE-2025-14881- CVSS 4.0
- 3.8 Low
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U - Weakness
- CWE-639
- Updated
- 2026-11-02
OSVGHSA-r2h2-g46h-8mx8
3.8
pretix has Broken Access Control Allowing Cross-User File Access via UUID
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
- Record
GHSA-r2h2-g46h-8mx8- CVSS 4.0
- 3.8 Low
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U - Weakness
- CWE-639
- Updated
- 2026-11-02
OSVPYSEC-2026-1803
3.8
pretix has Broken Access Control Allowing Cross-User File Access via UUID
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
- Record
PYSEC-2026-1803- CVSS 4.0
- 3.8 Low
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pretixPyPI |
2025.10.0 up to 2025.10.1 | 2025.10.1 |
pretixPyPI |
2025.9.0 up to 2025.9.3 | 2025.9.3 |
pretixPyPI |
before 2025.8.3 | 2025.8.3 |
pretixPyPI |
2025.9.0 up to 2025.9.3, plus listed versions 2025.9.12025.9.2 |
2025.9.3 |
pretixPyPI |
before 2025.8.3, plus listed versions 1.0.01.0.0b11.0.0b21.1.01.1.1 Show 45 moreShow less1.1.21.1.31.10.01.10.11.11.01.11.11.12.01.12.11.13.01.13.11.14.01.15.01.15.11.15.21.16.01.17.01.17.11.2.01.2.1.post21.2.21.3.01.3.0.post11.3.11.4.01.4.11.5.01.5.11.5.21.6.01.6.11.6.21.7.11.7.21.8.01.8.11.9.01.9.12.0.02.1.02.2.02.3.02.4.02.5.02.6.02.7.0 |
2025.8.3 |
pretixPyPI |
before 2025.8.3, 2025.9.0 up to 2025.9.3, 2025.10.0 up to 2025.10.1, plus listed versions 1.0.01.0.0b11.0.0b21.1.01.1.1 Show 45 moreShow less1.1.21.1.31.10.01.10.11.11.01.11.11.12.01.12.11.13.01.13.11.14.01.15.01.15.11.15.21.16.01.17.01.17.11.2.01.2.1.post21.2.21.3.01.3.0.post11.3.11.4.01.4.11.5.01.5.11.5.21.6.01.6.11.6.21.7.11.7.21.8.01.8.11.9.01.9.12.0.02.1.02.2.02.3.02.4.02.5.02.6.02.7.0 |
2025.8.32025.9.32025.10.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-14881 is a low vulnerability (CVSS 3.8) in Pretix, published December 19, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.25%, the 16th percentile. Fixed in pretix 2025.10.1.
References
pretix.eu/about/en/blog/20251218-release-2025-10-1
nvd.nist.gov/vuln/detail/CVE-2025-14881
github.com/pretix/pretix/commit/4b5651862c57c6e384822d1d23292342126c479a
pretix.eu/about/en/blog/20251219-release-2025-10-1
github.com/advisories/GHSA-r2h2-g46h-8mx8
pypi.org
github.com/CVEProject/cvelistV5/tree/main/cves/2025/14xxx/CVE-2025-14881.json
github.com/pretix/pretix
pypi.org/project/pretix
Left out here: 228 versions. The JSON record has them.