CVE-2025-14946
Libnbd: libnbd: arbitrary code execution via ssh argument injection through a malicious uri
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.8
Libnbd: libnbd: arbitrary code execution via ssh argument injection through a malicious uri
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
- Record
CVE-2025-14946- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-88
- Updated
- 2026-11-05
EUVDEUVD-2025-204536
4.8
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
- Record
EUVD-2025-204536- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-05
GitHub AdvisoriesGHSA-mcgc-vc2p-cf7x
4.8
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a...
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
- Record
GHSA-mcgc-vc2p-cf7x- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-88
- Updated
- 2026-11-02
NVD
4.8
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
- Record
CVE-2025-14946- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-88
- Updated
- 2026-11-05
OSV
4.8
Libnbd: libnbd: arbitrary code execution via ssh argument injection through a malicious uri
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
- Record
CVE-2025-14946- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-88
- Updated
- 2026-11-07
OSVDEBIAN-CVE-2025-14946
4.8
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
- Record
DEBIAN-CVE-2025-14946- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-06
OSVUBUNTU-CVE-2025-14946
4.8
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
- Record
UBUNTU-CVE-2025-14946- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
OSVopenSUSE-SU-2025:15842-1 No score
libnbd-1.24.0-2.1 on GA media
These are all security issues fixed in the libnbd-1.24.0-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:15842-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libnbdDebian:13 |
All versions, plus listed versions 1.22.2-11.22.3-11.22.5-11.24.0-11.24.0-2 Show 6 moreShow less1.24.0-2.11.24.1-11.24.2-11.24.2-21.24.3-11.24.4-1 |
None known |
libnbdDebian:14 |
before 1.22.5-1, plus listed versions 1.22.2-11.22.3-1 |
1.22.5-1 |
libnbdUbuntu:20.04:LTS |
All versions, plus listed versions 1.0.3-11.2.1-21.2.2-1ubuntu2 |
None known |
libnbdUbuntu:22.04:LTS |
All versions, plus listed versions 1.6.3-11.8.5-11.10.2-11.10.5-1 |
None known |
libnbdUbuntu:24.04:LTS |
All versions, plus listed versions 1.16.4-11.18.1-11.18.2-11.18.2-1build11.18.2-21.18.2-2build11.20.0-1 |
None known |
libnbdUbuntu:25.10 |
All versions, plus listed versions 1.22.0-11.22.2-1build11.22.2-1build2 |
None known |
libnbdUbuntu:26.04:LTS |
All versions, plus listed versions 1.22.2-1build21.24.0-2ubuntu11.24.1-1ubuntu61.24.2-1ubuntu1 |
None known |
libnbdopenSUSE:Tumbleweed |
before 1.24.0-2.1 | 1.24.0-2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | NVD, OSV | |
| facts | CVE List, EUVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-14946 is a medium vulnerability (CVSS 4.8) in Red Hat Libnbd, published December 19, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 3rd percentile. Fixed in libnbd 1.22.5-1.
References
access.redhat.com/security/cve/CVE-2025-14946
bugzilla.redhat.com/show_bug.cgi?id=2423789
libguestfs.org/libnbd-release-notes-1.24.1.html
nvd.nist.gov/vuln/detail/CVE-2025-14946
github.com/advisories/GHSA-mcgc-vc2p-cf7x
access.redhat.com/downloads/content/package-browser
Show 7 moreShow less
github.com/CVEProject/cvelistV5/tree/main/cves/2025/14xxx/CVE-2025-14946.json
gitlab.com/nbdkit/libnbd
security-tracker.debian.org/tracker/CVE-2025-14946
ubuntu.com/security/CVE-2025-14946
cve.org/CVERecord?id=CVE-2025-14946
lists.libguestfs.org/archives/list/[email protected]/thread/YZMBF3SJRWTRVT5L3KWSNHITFTRMQNTT
suse.com/security/cve/CVE-2025-14946