CVE-2025-1756
MongoDB Shell may be susceptible to local privilege escalation in Windows
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
MongoDB Shell may be susceptible to local privilege escalation in Windows
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0
- Record
CVE-2025-1756- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
EUVDEUVD-2025-5459
7.5
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0
- Record
EUVD-2025-5459- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-f5w3-73h4-jpcm
7.5
mongosh vulnerable to local privilege escalation
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0.
- Record
GHSA-f5w3-73h4-jpcm- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
NVD
7.5
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0
- Record
CVE-2025-1756- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
OSV
7.5
MongoDB Shell may be susceptible to local privilege escalation in Windows
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0
- Record
CVE-2025-1756- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
OSVGHSA-f5w3-73h4-jpcm
7.5
mongosh vulnerable to local privilege escalation
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0.
- Record
GHSA-f5w3-73h4-jpcm- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
Affected products
- mongodb mongosh
- mongodb inc mongosh
- redhat codeready linux builder eus
- redhat codeready linux builder for arm64 eus
- redhat codeready linux builder for ibm z systems eus
- redhat codeready linux builder for power little endian eus
- redhat enterprise linux eus
- redhat enterprise linux for arm 64
- redhat enterprise linux for arm 64 eus
- redhat enterprise linux for ibm z systems
- redhat enterprise linux for ibm z systems eus
- redhat enterprise linux for power little endian eus
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mongoshnpm |
before 2.3.0 | 2.3.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-1756 is a high vulnerability (CVSS 7.5) in Mongodb Mongosh, published February 27, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.16%, the 5th percentile. Fixed in mongosh 2.3.0.