CVE-2025-1801
Aap-gateway: aap-gateway privilege escalation
A flaw was found in the Ansible aap-gateway. Concurrent requests handled by the gateway grpc service can result in concurrency issues due to race condition requests against the proxy. This issue potentially allows a less privileged user to obtain the JWT of a greater privileged user, enabling the server to be jeopardized. A user session or confidential data might be vulnerable.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.1
Aap-gateway: aap-gateway privilege escalation
A flaw was found in the Ansible aap-gateway. Concurrent requests handled by the gateway grpc service can result in concurrency issues due to race condition requests against the proxy. This issue potentially allows a less privileged user to obtain the JWT of a greater privileged user, enabling the server to be jeopardized. A user session or confidential data might be vulnerable.
- Record
CVE-2025-1801- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-362
- Updated
- 2026-11-04
EUVDEUVD-2025-5589
8.1
A flaw was found in the Ansible aap-gateway. Concurrent requests handled by the gateway grpc service can result in concurrency issues due to race condition requests against the proxy. This issue potentially allows a less privileged user to obtain the JWT of a greater privileged user, enabling the server to be jeopardized. A user session or confidential data might be vulnerable.
- Record
EUVD-2025-5589- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-04
GitHub AdvisoriesGHSA-fj43-p45h-jjgv
8.1
A flaw was found in the Ansible aap-gateway. Concurrent requests handled by the gateway grpc...
A flaw was found in the Ansible aap-gateway. Concurrent requests handled by the gateway grpc service can result in concurrency issues due to race condition requests against the proxy. This issue potentially allows a less privileged user to obtain the JWT of a greater privileged user, enabling the server to be jeopardized. A user session or confidential data might be vulnerable.
- Record
GHSA-fj43-p45h-jjgv- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-362
- Updated
- 2026-11-02
NVD
8.1
A flaw was found in the Ansible aap-gateway. Concurrent requests handled by the gateway grpc service can result in concurrency issues due to race condition requests against the proxy. This issue potentially allows a less privileged user to obtain the JWT of a greater privileged user, enabling the server to be jeopardized. A user session or confidential data might be vulnerable.
- Record
CVE-2025-1801- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-362
- Updated
- 2026-11-04
OSVRHSA-2025:1954
8.1
Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update
- Record
RHSA-2025:1954- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
automation-gatewayRed Hat:ansible_automation_platform:2.5::el8 |
before 0:2.5.20250305-1.el8ap | 0:2.5.20250305-1.el8ap |
automation-gateway-configRed Hat:ansible_automation_platform:2.5::el8 |
before 0:2.5.20250305-1.el8ap | 0:2.5.20250305-1.el8ap |
automation-gateway-serverRed Hat:ansible_automation_platform:2.5::el8 |
before 0:2.5.20250305-1.el8ap | 0:2.5.20250305-1.el8ap |
automation-gatewayRed Hat:ansible_automation_platform:2.5::el9 |
before 0:2.5.20250305-1.el9ap | 0:2.5.20250305-1.el9ap |
automation-gateway-configRed Hat:ansible_automation_platform:2.5::el9 |
before 0:2.5.20250305-1.el9ap | 0:2.5.20250305-1.el9ap |
automation-gateway-serverRed Hat:ansible_automation_platform:2.5::el9 |
before 0:2.5.20250305-1.el9ap | 0:2.5.20250305-1.el9ap |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | CVE List | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-1801 is a high vulnerability (CVSS 8.1) in Red Hat Ansible Automation Platform 2.5 For Rhel 8, published March 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 25th percentile. Fixed in automation-gateway 0:2.5.20250305-1.el8ap.
References
access.redhat.com/errata/RHSA-2025:1954
access.redhat.com/security/cve/CVE-2025-1801
bugzilla.redhat.com/show_bug.cgi?id=2349081
nvd.nist.gov/vuln/detail/CVE-2025-1801
github.com/advisories/GHSA-fj43-p45h-jjgv
access.redhat.com/security/updates/classification
security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_1954.json
cve.org/CVERecord?id=CVE-2025-1801