Every CVE Search/ Get API key

CVE-2025-24367

Cacti allows Arbitrary File Creation leading to RCE

8.7 HighPublic exploitFix available

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

58.8%Up 58.8 points since Jan 28, 2025
90%50%10%1%

What each source reports

CVE List Score used 8.7

Cacti allows Arbitrary File Creation leading to RCE

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Record
CVE-2025-24367
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-144
Updated
2026-11-02
EUVDEUVD-2025-3681 8.7

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Record
EUVD-2025-3681
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
NVD 8.7

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Record
CVE-2025-24367
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-144
Updated
2026-11-02
OSVALPINE-CVE-2025-24367 8.8

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Record
ALPINE-CVE-2025-24367
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.7

Cacti allows Arbitrary File Creation leading to RCE

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Record
CVE-2025-24367
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-144
Updated
2026-11-02
OSVDEBIAN-CVE-2025-24367 8.8

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Record
DEBIAN-CVE-2025-24367
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2025-24367 8.7

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Record
UBUNTU-CVE-2025-24367
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cacti
Alpine:v3.21
before 1.2.29-r0
1.2.29-r0
cacti
Alpine:v3.22
before 1.2.29-r0
1.2.29-r0
cacti
Alpine:v3.23
before 1.2.29-r0
1.2.29-r0
cacti
Alpine:v3.24
before 1.2.29-r0
1.2.29-r0
cacti
Debian:12
before 1.2.24+ds1-1+deb12u5, plus listed versions
1.2.24+ds1-11.2.24+ds1-1+deb12u11.2.24+ds1-1+deb12u21.2.24+ds1-1+deb12u31.2.24+ds1-1+deb12u4
1.2.24+ds1-1+deb12u5
cacti
Debian:13
before 1.2.28+ds1-4
1.2.28+ds1-4
cacti
Debian:14
before 1.2.28+ds1-4
1.2.28+ds1-4
cacti
Debian:11
before 1.2.16+ds1-2+deb11u5, plus listed versions
1.2.16+ds1-21.2.16+ds1-2+deb11u11.2.16+ds1-2+deb11u21.2.16+ds1-2+deb11u31.2.16+ds1-2+deb11u4
1.2.16+ds1-2+deb11u5
cacti
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
0.8.8b+dfsg-30.8.8b+dfsg-50.8.8b+dfsg-5ubuntu0.10.8.8b+dfsg-5ubuntu0.20.8.8b+dfsg-5ubuntu0.2+esm10.8.8b+dfsg-5ubuntu0.2+esm2
None known
cacti
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
0.8.8f+ds1-20.8.8f+ds1-30.8.8f+ds1-40.8.8f+ds1-4ubuntu10.8.8f+ds1-4ubuntu2
Show 7 moreShow less
0.8.8f+ds1-4ubuntu30.8.8f+ds1-4ubuntu40.8.8f+ds1-4ubuntu4.16.040.8.8f+ds1-4ubuntu4.16.04.10.8.8f+ds1-4ubuntu4.16.04.20.8.8f+ds1-4ubuntu4.16.04.2+esm10.8.8f+ds1-4ubuntu4.16.04.2+esm2
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
cacti
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
1.1.18+ds1-11.1.27+ds1-21.1.27+ds1-31.1.28+ds1-21.1.35+ds1-1
Show 5 moreShow less
1.1.36+ds1-11.1.38+ds1-11.1.38+ds1-1ubuntu0.1~esm11.1.38+ds1-1ubuntu0.1~esm31.1.38+ds1-1ubuntu0.1~esm4
None known
cacti
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
1.2.4+ds1-2ubuntu31.2.9+ds1-1ubuntu11.2.9+ds1-1ubuntu21.2.10+ds1-1ubuntu11.2.10+ds1-1ubuntu1+esm11.2.10+ds1-1ubuntu1.11.2.10+ds1-1ubuntu1.1+esm11.2.10+ds1-1ubuntu1.1+esm2
None known
cacti
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1.2.16+ds1-2ubuntu11.2.19+ds1-2ubuntu11.2.19+ds1-2ubuntu1+esm11.2.19+ds1-2ubuntu1.11.2.19+ds1-2ubuntu1.1+esm11.2.19+ds1-2ubuntu1.1+esm2
None known
cacti
Ubuntu:24.04:LTS
All versions, plus listed versions
1.2.25+ds1-21.2.26+ds1-11.2.26+ds1-1ubuntu0.1
None known
cacti
Ubuntu:25.10
All versions, plus listed versions
1.2.28+ds1-4ubuntu11.2.30+ds1-1ubuntu1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
MetasploitCacti Graph Template authenticated RCE versions prior to 1.2.292025-01-27
PoC in GitHubTheCyberGeek/CVE-2025-24367-Cacti-PoC2025-10-30
PoC in GitHubr3vpwnx/CVE-2025-243672025-12-12
PoC in GitHubSoftAndoWetto/CVE-2025-24367-PoC-Cacti2025-12-14
PoC in GitHubmatesz44/CVE-2025-243672026-01-15
PoC in GitHubShoshinMaster/CVE-2025-243672026-01-19
PoC in GitHubdantedansh/CVE-2025-24367-Cacti-Exploit2026-05-02

History

History
RecordedChangedSources
affected, aliases, exploits, referencesOSV
first indexedCVE List, EUVD, Metasploit, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-24367 is a high vulnerability (CVSS 8.7) in Cacti, published January 27, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 58.8%, the 99th percentile. Fixed in cacti 1.2.29-r0.

References

MoveEnter Open