CVE-2025-24857
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot...
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot) before 2017.11 and Qualcomm chips IPQ4019, IPQ5018, IPQ5322, IPQ6018, IPQ8064, IPQ8074, and IPQ9574 could allow an attacker to execute arbitrary code.
Attack profile
How easy it is to exploit
- Attack vector
- Physical
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.6
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot) before 2017.11 and Qualcomm chips IPQ4019, IPQ5018, IPQ5322, IPQ6018, IPQ8064, IPQ8074, and IPQ9574 could allow an attacker to execute arbitrary code.
- Record
CVE-2025-24857- CVSS 3.1
- 7.6 High
CVSS:3.1/AC:L/AV:P/A:H/C:H/I:H/PR:N/S:C/UI:N - Weakness
- CWE-284
- Updated
- 2026-11-02
EUVDEUVD-2025-202621
7.6
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot) before 2017.11 and Qualcomm chips IPQ4019, IPQ5018, IPQ5322, IPQ6018, IPQ8064, IPQ8074, and IPQ9574 could allow an attacker to execute arbitrary code.
- Record
EUVD-2025-202621- CVSS 3.1
- 7.6 High
CVSS:3.1/AC:L/AV:P/A:H/C:H/I:H/PR:N/S:C/UI:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-v72w-97m6-622r
7.6
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot...
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot) before 2017.11 and Qualcomm chips IPQ4019, IPQ5018, IPQ5322, IPQ6018, IPQ8064, IPQ8074, and IPQ9574 could allow an attacker to execute arbitrary code.
- Record
GHSA-v72w-97m6-622r- CVSS 3.1
- 7.6 High
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-02
NVD
7.6
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot) before 2017.11 and Qualcomm chips IPQ4019, IPQ5018, IPQ5322, IPQ6018, IPQ8064, IPQ8074, and IPQ9574 could allow an attacker to execute arbitrary code.
- Record
CVE-2025-24857- CVSS 3.1
- 7.6 High
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-04
OSV
7.6
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot) before 2017.11 and Qualcomm chips IPQ4019, IPQ5018, IPQ5322, IPQ6018, IPQ8064, IPQ8074, and IPQ9574 could allow an attacker to execute arbitrary code.
- Record
CVE-2025-24857- CVSS 3.1
- 7.6 High
CVSS:3.1/AC:L/AV:P/A:H/C:H/I:H/PR:N/S:C/UI:N - Updated
- 2026-11-05
OSVDEBIAN-CVE-2025-24857
7.6
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot) before 2017.11 and Qualcomm chips IPQ4019, IPQ5018, IPQ5322, IPQ6018, IPQ8064, IPQ8074, and IPQ9574 could allow an attacker to execute arbitrary code.
- Record
DEBIAN-CVE-2025-24857- CVSS 3.1
- 7.6 High
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-05
OSVUBUNTU-CVE-2025-24857
7.6
Improper access control for volatile memory containing boot code in Universal Boot Loader (U-Boot) before 2017.11 and Qualcomm chips IPQ4019, IPQ5018, IPQ5322, IPQ6018, IPQ8064, IPQ8074, and IPQ9574 could allow an attacker to execute arbitrary code.
- Record
UBUNTU-CVE-2025-24857- CVSS 3.1
- 7.6 High
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
u-bootDebian:12 |
before 2017.11+dfsg1-2 | 2017.11+dfsg1-2 |
u-bootDebian:13 |
before 2017.11+dfsg1-2 | 2017.11+dfsg1-2 |
u-bootDebian:14 |
before 2017.11+dfsg1-2 | 2017.11+dfsg1-2 |
bootUbuntu:14.04:LTS |
All versions, plus listed versions 1.3-9-1 |
None known |
bootUbuntu:16.04:LTS |
All versions, plus listed versions 1.3-17-1 |
None known |
bootUbuntu:18.04:LTS |
All versions, plus listed versions 1.3-20-1build11.3-20-1.1 |
None known |
bootUbuntu:20.04:LTS |
All versions, plus listed versions 1.3-23-21.3-24-11.3-24-2 |
None known |
bootUbuntu:22.04:LTS |
All versions, plus listed versions 1.3-27-11.3-28-2 |
None known |
bootUbuntu:24.04:LTS |
All versions, plus listed versions 1.3-28.1-11.3-29-11.3-30-1 |
None known |
bootUbuntu:25.10 |
All versions, plus listed versions 1.3-31-1 |
None known |
bootUbuntu:26.10 |
All versions, plus listed versions 1.3-32-1 |
None known |
bootUbuntu:26.04:LTS |
All versions, plus listed versions 1.3-31-11.3-32-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | NVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-24857 is a high vulnerability (CVSS 7.6) in Denx U-boot, published December 10, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.27%, the 19th percentile. Fixed in u-boot 2017.11+dfsg1-2.
References
cisa.gov/news-events/ics-advisories/icsa-25-343-01
nvd.nist.gov/vuln/detail/CVE-2025-24857
github.com/advisories/GHSA-v72w-97m6-622r
github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24857.json
security-tracker.debian.org/tracker/CVE-2025-24857
ubuntu.com/security/CVE-2025-24857
cve.org/CVERecord?id=CVE-2025-24857