Every CVE Search/ Get API key

CVE-2025-25004

PowerShell Elevation of Privilege Vulnerability

7.3 HighFix available

Improper access control in Microsoft PowerShell allows an authorized attacker to elevate privileges locally.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.49%Up 0.4 points since Oct 15, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.3

PowerShell Elevation of Privilege Vulnerability

Improper access control in Microsoft PowerShell allows an authorized attacker to elevate privileges locally.

Record
CVE-2025-25004
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C
Weakness
CWE-284
Updated
2026-11-02
EUVDEUVD-2025-34354 7.3

Improper access control in Microsoft PowerShell allows an authorized attacker to elevate privileges locally.

Record
EUVD-2025-34354
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C
Updated
2026-11-02
GitHub AdvisoriesGHSA-pcw6-863g-fcmj 7.3

Improper access control in Microsoft PowerShell allows an authorized attacker to elevate...

Improper access control in Microsoft PowerShell allows an authorized attacker to elevate privileges locally.

Record
GHSA-pcw6-863g-fcmj
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-284
Updated
2026-11-02
NVD 7.3

Improper access control in Microsoft PowerShell allows an authorized attacker to elevate privileges locally.

Record
CVE-2025-25004
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-284
Updated
2026-11-02
OSV 7.3

Improper access control in Microsoft PowerShell allows an authorized attacker to elevate privileges locally.

Record
CVE-2025-25004
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-powershell-2025-25004 No score

PowerShell Elevation of Privilege Vulnerability

Improper access control in Microsoft PowerShell allows an authorized attacker to elevate privileges locally.

Record
BIT-powershell-2025-25004
Updated
2026-11-02

Affected products

Show 28 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
powershell
Bitnami
7.4.0 up to 7.4.13, 7.5.0 up to 7.5.4
7.4.137.5.4

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-25004 is a high vulnerability (CVSS 7.3) in Microsoft Powershell, published October 14, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.49%, the 42nd percentile. Fixed in powershell 7.4.13.

References

MoveEnter Open