Every CVE Search/ Get API key

CVE-2025-25274

Unauthorized Command Execution in Archived Channels

4.3 MediumFix available

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.38%Up 0.3 points since Mar 21, 2025
90%50%10%1%

What each source reports

CVE List Score used 4.3

Unauthorized Command Execution in Archived Channels

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.

Record
CVE-2025-25274
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2025-7223 4.3

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.

Record
EUVD-2025-7223
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-4v65-xqcj-wpgg 4.3

Mattermost Fails to Restrict Command Execution in Archived Channels

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.

Record
GHSA-4v65-xqcj-wpgg
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-77, CWE-863
Updated
2026-11-02
NVD 4.3

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.

Record
CVE-2025-25274
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-863, CWE-77
Updated
2026-11-02
OSV 4.3

Unauthorized Command Execution in Archived Channels

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.

Record
CVE-2025-25274
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
OSVGHSA-4v65-xqcj-wpgg 4.3

Mattermost Fails to Restrict Command Execution in Archived Channels

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.

Record
GHSA-4v65-xqcj-wpgg
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-77, CWE-863
Updated
2026-11-02
OSVBIT-mattermost-2025-25274 No score

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.

Record
BIT-mattermost-2025-25274
Updated
2026-11-02
OSVGO-2025-3550 No score

Mattermost Fails to Restrict Command Execution in Archived Channels in github.com/mattermost/mattermost-server

Mattermost Fails to Restrict Command Execution in Archived Channels in github.com/mattermost/mattermost-server

Record
GO-2025-3550
Updated
2026-11-02
OSVopenSUSE-SU-2025:14937-1 No score

govulncheck-vulndb-0.0.20250327T184518-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250327T184518-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14937-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/mattermost/mattermost/server/v8
Go
10.4.0 up to 10.4.3
10.4.3
github.com/mattermost/mattermost/server/v8
Go
10.3.0 up to 10.3.4
10.3.4
github.com/mattermost/mattermost/server/v8
Go
9.11.0 up to 9.11.9
9.11.9
github.com/mattermost/mattermost/server/v8
Go
10.5.0 to 10.5.0
10.5.1
mattermost
Bitnami
9.11.0 up to 10.0.0, 10.3.0 up to 10.5.1
10.0.010.5.1
github.com/mattermost/mattermost/server/v8
Go
10.5.0 up to 10.5.1
10.5.1
github.com/mattermost/mattermost-server
Go
9.11.0+incompatible up to 9.11.9+incompatible, 10.3.0+incompatible up to 10.3.4+incompatible, 10.4.0+incompatible up to 10.4.3+incompatible, 10.5.0+incompatible up to 10.5.1+incompatible
9.11.9+incompatible10.3.4+incompatible10.4.3+incompatible10.5.1+incompatible
github.com/mattermost/mattermost-server/v5
Go
All versions None known
github.com/mattermost/mattermost-server/v6
Go
All versions None known
github.com/mattermost/mattermost/server/v8
Go
All versions None known
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 30 CVEs
before 0.0.20250327T184518-1.1
0.0.20250327T184518-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-25274 is a medium vulnerability (CVSS 4.3) in Mattermost, published March 21, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. Fixed in github.com/mattermost/mattermost/server/v8 10.4.3.

References

Show 30 moreShow less
MoveEnter Open