CVE-2025-2581
xmedcon DICOM File malloc integer underflow
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this vulnerability is the function malloc of the component DICOM File Handler. The manipulation leads to integer underflow. The attack can be launched remotely. Upgrading to version 0.25.1 is able to address this issue. It is recommended to upgrade the affected component.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Passive
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.3
xmedcon DICOM File malloc integer underflow
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this vulnerability is the function malloc of the component DICOM File Handler. The manipulation leads to integer underflow. The attack can be launched remotely. Upgrading to version 0.25.1 is able to address this issue. It is recommended to upgrade the affected component.
- Record
CVE-2025-2581- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - CVSS 2.0
- 5.0
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-191, CWE-189
- Updated
- 2026-11-02
EUVDEUVD-2025-7270
5.3
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this vulnerability is the function malloc of the component DICOM File Handler. The manipulation leads to integer underflow. The attack can be launched remotely. Upgrading to version 0.25.1 is able to address this issue. It is recommended to upgrade the affected component.
- Record
EUVD-2025-7270- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8h26-hc89-g7w7
5.3
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this...
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this vulnerability is the function malloc of the component DICOM File Handler. The manipulation leads to integer underflow. The attack can be launched remotely. Upgrading to version 0.25.1 is able to address this issue. It is recommended to upgrade the affected component.
- Record
GHSA-8h26-hc89-g7w7- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - Weakness
- CWE-191
- Updated
- 2026-11-02
NVD
5.3
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this vulnerability is the function malloc of the component DICOM File Handler. The manipulation leads to integer underflow. The attack can be launched remotely. Upgrading to version 0.25.1 is able to address this issue. It is recommended to upgrade the affected component.
- Record
CVE-2025-2581- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-189, CWE-191
- Updated
- 2026-11-02
OSV
7.5
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this vulnerability is the function malloc of the component DICOM File Handler. The manipulation leads to integer underflow. The attack can be launched remotely. Upgrading to version 0.25.1 is able to address this issue. It is recommended to upgrade the affected component.
- Record
CVE-2025-2581- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-2581
7.5
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this vulnerability is the function malloc of the component DICOM File Handler. The manipulation leads to integer underflow. The attack can be launched remotely. Upgrading to version 0.25.1 is able to address this issue. It is recommended to upgrade the affected component.
- Record
DEBIAN-CVE-2025-2581- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-2581
5.3
A vulnerability has been found in xmedcon 0.25.0 and classified as problematic. Affected by this vulnerability is the function malloc of the component DICOM File Handler. The manipulation leads to integer underflow. The attack can be launched remotely. Upgrading to version 0.25.1 is able to address this issue. It is recommended to upgrade the affected component.
- Record
UBUNTU-CVE-2025-2581- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xmedconDebian:12 |
before 0.23.0-gtk3+dfsg-1+deb12u2, plus listed versions 0.23.0-gtk3+dfsg-10.23.0-gtk3+dfsg-1+deb12u1 |
0.23.0-gtk3+dfsg-1+deb12u2 |
xmedconDebian:13 |
before 0.25.1-gtk3+dfsg-1 | 0.25.1-gtk3+dfsg-1 |
xmedconDebian:14 |
before 0.25.1-gtk3+dfsg-1 | 0.25.1-gtk3+dfsg-1 |
xmedconDebian:11 |
before 0.16.3+dfsg-1+deb11u2, plus listed versions 0.16.3+dfsg-10.16.3+dfsg-1+deb11u1 |
0.16.3+dfsg-1+deb11u2 |
xmedconUbuntu:16.04:LTS |
All versions, plus listed versions 0.13.0-20.14.1-1 |
None known |
xmedconUbuntu:18.04:LTS |
All versions, plus listed versions 0.14.1-1build10.14.1-2 |
None known |
xmedconUbuntu:20.04:LTS |
All versions, plus listed versions 0.16.1+dfsg-1 |
None known |
xmedconUbuntu:22.04:LTS |
All versions, plus listed versions 0.16.3+dfsg-10.21.2+dfsg-1 |
None known |
xmedconUbuntu:24.04:LTS |
All versions, plus listed versions 0.23.0-gtk3+dfsg-10.23.0-gtk3+dfsg-1.1build10.23.0-gtk3+dfsg-1.1build20.23.0-gtk3+dfsg-1.1build3 |
None known |
xmedconUbuntu:25.10 |
All versions, plus listed versions 0.24.0-gtk3+dfsg-20.25.1-gtk3+dfsg-1 |
None known |
xmedconUbuntu:26.10 |
All versions, plus listed versions 0.25.1-gtk3+dfsg-1build10.26.1-gtk3+dfsg-1 |
None known |
xmedconUbuntu:26.04:LTS |
All versions, plus listed versions 0.25.1-gtk3+dfsg-10.25.1-gtk3+dfsg-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-2581 is a medium vulnerability (CVSS 5.3) in Xmedcon Project Xmedcon, published March 21, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.64%, the 50th percentile. Fixed in xmedcon 0.23.0-gtk3+dfsg-1+deb12u2.