CVE-2025-25975
Prototype Pollution Vulnerability in parse-git-config
An issue in parse-git-config v.3.0.0 allows an attacker to obtain sensitive information via the expandKeys function
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.5
An issue in parse-git-config v.3.0.0 allows an attacker to obtain sensitive information via the expandKeys function
- Record
CVE-2025-25975- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
EUVDEUVD-2025-6799
7.5
An issue in parse-git-config v.3.0.0 allows an attacker to obtain sensitive information via the expandKeys function
- Record
EUVD-2025-6799- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8g77-54rh-46hx
8.9
Prototype Pollution Vulnerability in parse-git-config
An issue in parse-git-config v.3.0.0 allows an attacker to obtain sensitive information via the expandKeys function.
- Record
GHSA-8g77-54rh-46hx- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200, CWE-1321
- Updated
- 2026-11-02
NVD
7.5
An issue in parse-git-config v.3.0.0 allows an attacker to obtain sensitive information via the expandKeys function
- Record
CVE-2025-25975- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
7.5
An issue in parse-git-config v.3.0.0 allows an attacker to obtain sensitive information via the expandKeys function
- Record
CVE-2025-25975- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-8g77-54rh-46hx
8.9
Prototype Pollution Vulnerability in parse-git-config
An issue in parse-git-config v.3.0.0 allows an attacker to obtain sensitive information via the expandKeys function.
- Record
GHSA-8g77-54rh-46hx- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-1321, CWE-200
- Updated
- 2026-11-02
OSVCLSA-2026-1774916743 No score
TuxCare security update for parse-git-config (1 CVE)
TuxCare rebuilt parse-git-config to address 1 CVE. Fixed in 3.0.0-tuxcare.1.
- Record
CLSA-2026-1774916743- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
parse-git-confignpm |
through 3.0.0 | None known |
parse-git-configTuxCare:npm |
3.0.0-tuxcare.0 up to 3.0.0-tuxcare.1, plus listed versions 3.0.0 |
3.0.0-tuxcare.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-25975 is a high vulnerability (CVSS 7.5) in Jonschlinkert Parse-git-config, published March 12, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 41st percentile. Fixed in parse-git-config 3.0.0-tuxcare.1.