Every CVE Search/ Get API key

CVE-2025-25977

canvg Prototype Pollution vulnerability

9.8 CriticalFix available

An issue in canvg v.4.0.2 allows an attacker to execute arbitrary code via the Constructor of the class StyleElement.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.71%Up 0.7 points since Mar 11, 2025
90%50%10%1%

What each source reports

CVE List Score used 9.8

An issue in canvg v.4.0.2 allows an attacker to execute arbitrary code via the Constructor of the class StyleElement.

Record
CVE-2025-25977
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1321
Updated
2026-11-02
EUVDEUVD-2025-6266 9.8

An issue in canvg v.4.0.2 allows an attacker to execute arbitrary code via the Constructor of the class StyleElement.

Record
EUVD-2025-6266
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-v2mw-5mch-w8c5 8.9

canvg Prototype Pollution vulnerability

An issue in canvg prior to v.4.0.3 and v3.0.11 can lead to prototype pollution via the Constructor of the class StyleElement.

Record
GHSA-v2mw-5mch-w8c5
CVSS 4.0
8.9 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
Weakness
CWE-1321
Updated
2026-11-02
NVD 9.8

An issue in canvg v.4.0.2 allows an attacker to execute arbitrary code via the Constructor of the class StyleElement.

Record
CVE-2025-25977
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1321
Updated
2026-11-02
OSV 9.8

An issue in canvg v.4.0.2 allows an attacker to execute arbitrary code via the Constructor of the class StyleElement.

Record
CVE-2025-25977
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2025-25977 9.8

An issue in canvg v.4.0.2 allows an attacker to execute arbitrary code via the Constructor of the class StyleElement.

Record
DEBIAN-CVE-2025-25977
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-v2mw-5mch-w8c5 8.9

canvg Prototype Pollution vulnerability

An issue in canvg prior to v.4.0.3 and v3.0.11 can lead to prototype pollution via the Constructor of the class StyleElement.

Record
GHSA-v2mw-5mch-w8c5
CVSS 4.0
8.9 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
Weakness
CWE-1321
Updated
2026-11-02
OSVUBUNTU-CVE-2025-25977 9.8

An issue in canvg v.4.0.2 allows an attacker to execute arbitrary code via the Constructor of the class StyleElement.

Record
UBUNTU-CVE-2025-25977
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
canvg
npm
4.0.0 up to 4.0.3
4.0.3
canvg
npm
before 3.0.11
3.0.11
znuny
Debian:12
All versions, plus listed versions
6.3.2-36.3.3-16.3.3-1~bpo11+16.3.4-16.3.4-1~bpo11+1
Show 44 moreShow less
6.4.2-16.4.2-1~bpo11+16.4.2-26.4.3-16.4.3-1~bpo11+16.4.4-16.4.5-16.4.5-1~bpo11+16.4.5-26.5.1-16.5.10-16.5.10-1~bpo12+16.5.11-16.5.11-1~bpo12+16.5.13-16.5.14-16.5.14-1~bpo12+16.5.15-16.5.15-26.5.15-2~bpo12+16.5.16-16.5.18-16.5.18-1~bpo13+16.5.19-16.5.20-16.5.21-16.5.22-16.5.22-1~bpo13+16.5.23-16.5.23-1~bpo13+16.5.24-16.5.24-1~bpo13+16.5.3-16.5.3-1~bpo12+16.5.4-16.5.4-1~bpo12+16.5.5-16.5.5-1~bpo12+16.5.6-16.5.6-1~bpo12+16.5.8-16.5.8-1~bpo12+16.5.9-16.5.9-1~bpo12+1
None known
znuny
Debian:13
All versions, plus listed versions
6.3.2-36.3.3-16.3.3-1~bpo11+16.3.4-16.3.4-1~bpo11+1
Show 44 moreShow less
6.4.2-16.4.2-1~bpo11+16.4.2-26.4.3-16.4.3-1~bpo11+16.4.4-16.4.5-16.4.5-1~bpo11+16.4.5-26.5.1-16.5.10-16.5.10-1~bpo12+16.5.11-16.5.11-1~bpo12+16.5.13-16.5.14-16.5.14-1~bpo12+16.5.15-16.5.15-26.5.15-2~bpo12+16.5.16-16.5.18-16.5.18-1~bpo13+16.5.19-16.5.20-16.5.21-16.5.22-16.5.22-1~bpo13+16.5.23-16.5.23-1~bpo13+16.5.24-16.5.24-1~bpo13+16.5.3-16.5.3-1~bpo12+16.5.4-16.5.4-1~bpo12+16.5.5-16.5.5-1~bpo12+16.5.6-16.5.6-1~bpo12+16.5.8-16.5.8-1~bpo12+16.5.9-16.5.9-1~bpo12+1
None known
znuny
Debian:14
before 6.5.24-1, plus listed versions
6.3.2-36.3.3-16.3.3-1~bpo11+16.3.4-16.3.4-1~bpo11+1
Show 43 moreShow less
6.4.2-16.4.2-1~bpo11+16.4.2-26.4.3-16.4.3-1~bpo11+16.4.4-16.4.5-16.4.5-1~bpo11+16.4.5-26.5.1-16.5.10-16.5.10-1~bpo12+16.5.11-16.5.11-1~bpo12+16.5.13-16.5.14-16.5.14-1~bpo12+16.5.15-16.5.15-26.5.15-2~bpo12+16.5.16-16.5.18-16.5.18-1~bpo13+16.5.19-16.5.20-16.5.21-16.5.22-16.5.22-1~bpo13+16.5.23-16.5.23-1~bpo13+16.5.24-1~bpo13+16.5.3-16.5.3-1~bpo12+16.5.4-16.5.4-1~bpo12+16.5.5-16.5.5-1~bpo12+16.5.6-16.5.6-1~bpo12+16.5.8-16.5.8-1~bpo12+16.5.9-16.5.9-1~bpo12+1
6.5.24-1
otrs2
Ubuntu:16.04:LTS
All versions, plus listed versions
4.0.10-15.0.1-15.0.1-25.0.2-15.0.3-15.0.5-15.0.6-15.0.7-1
None known
otrs2
Ubuntu:18.04:LTS
All versions, plus listed versions
5.0.23-15.0.24-16.0.1-16.0.2-16.0.3-16.0.4-16.0.5-1
None known
otrs2
Ubuntu:20.04:LTS
All versions, plus listed versions
6.0.20-16.0.23-26.0.24-16.0.25-16.0.25-26.0.25-36.0.26-1
None known
otrs2
Ubuntu:22.04:LTS
All versions, plus listed versions
6.0.32-66.1.2-16.2.1-16.2.2-2
None known
znuny
Ubuntu:24.04:LTS
All versions, plus listed versions
6.5.3-16.5.4-16.5.5-16.5.6-1
None known
znuny
Ubuntu:26.10
All versions, plus listed versions
6.5.18-16.5.20-16.5.21-16.5.22-16.5.23-1
None known
znuny
Ubuntu:26.04:LTS
All versions, plus listed versions
6.5.15-26.5.18-1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-25977 is a critical vulnerability (CVSS 9.8) in Canvg, published March 10, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.71%, the 53rd percentile. Fixed in canvg 4.0.3.

References

Show 5 moreShow less
MoveEnter Open