CVE-2025-26803
Phusion Passenger denial of service
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.3
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
CVE-2025-26803- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-908
- Updated
- 2026-11-02
EUVDEUVD-2025-4281
5.3
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
EUVD-2025-4281- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-2cj2-qqxj-5m3r
5.3
Phusion Passenger denial of service
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
GHSA-2cj2-qqxj-5m3r- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-908
- Updated
- 2026-11-02
NVD
5.3
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
CVE-2025-26803- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-908
- Updated
- 2026-11-02
OSV
5.3
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
CVE-2025-26803- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-908
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-26803
7.5
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
DEBIAN-CVE-2025-26803- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVGHSA-2cj2-qqxj-5m3r
5.3
Phusion Passenger denial of service
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
GHSA-2cj2-qqxj-5m3r- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-908
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-26803
5.3
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
UBUNTU-CVE-2025-26803- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVBIT-passenger-2025-26803 No score
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
BIT-passenger-2025-26803- Updated
- 2026-11-02
OSVBIT-passenger-apache-module-2025-26803 No score
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
BIT-passenger-apache-module-2025-26803- Updated
- 2026-11-02
OSVBIT-passenger-nginx-module-2025-26803 No score
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
- Record
BIT-passenger-nginx-module-2025-26803- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
passengerRubyGems |
6.0.21 up to 6.0.26 | 6.0.26 |
passengerBitnami |
6.0.21 up to 6.0.26 | 6.0.26 |
passenger-apache-moduleBitnami |
6.0.21 up to 6.0.26 | 6.0.26 |
passenger-nginx-moduleBitnami |
6.0.21 up to 6.0.26 | 6.0.26 |
passengerDebian:13 |
before 6.0.26+ds-1 | 6.0.26+ds-1 |
passengerDebian:14 |
before 6.0.26+ds-1 | 6.0.26+ds-1 |
passengerRubyGems |
6.0.21 up to 6.0.26, plus listed versions 6.0.226.0.236.0.246.0.25 |
6.0.26 |
passengerUbuntu:25.10 |
All versions, plus listed versions 6.0.24+ds-36.0.26+ds-1.1 |
None known |
passengerUbuntu:26.10 |
All versions, plus listed versions 6.1.1+ds-16.1.1+ds-1build1 |
None known |
passengerUbuntu:26.04:LTS |
All versions, plus listed versions 6.0.26+ds-1.16.1.1+ds-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-26803 is a medium vulnerability (CVSS 5.3) in Phusion Passenger, published February 24, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 50th percentile. Fixed in passenger 6.0.26.
References
phusionpassenger.com/support
github.com/phusion/passenger/compare/release-6.0.25...release-6.0.26
github.com/phusion/passenger/releases/tag/release-6.0.26
blog.phusion.nl/2025/02/19/passenger-6-0-26
github.com/phusion/passenger/commit/bb15591646687064ab2d578d5f9660b2a4168017
nvd.nist.gov/vuln/detail/CVE-2025-26803
Show 7 moreShow less
github.com/rubysec/ruby-advisory-db/blob/master/gems/passenger/CVE-2025-26803.yml
github.com/advisories/GHSA-2cj2-qqxj-5m3r
github.com/CVEProject/cvelistV5/tree/main/cves/2025/26xxx/CVE-2025-26803.json
security-tracker.debian.org/tracker/CVE-2025-26803
github.com/phusion/passenger
ubuntu.com/security/CVE-2025-26803
cve.org/CVERecord?id=CVE-2025-26803