Every CVE Search/ Get API key

CVE-2025-27110

Libmodsecurity3 has possible bypass of encoded HTML entities

7.9 HighFix available

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
None

Exploit likelihood

0.48%Up 0.4 points since Feb 27, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.9

Libmodsecurity3 has possible bypass of encoded HTML entities

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Record
CVE-2025-27110
CVSS 4.0
7.9 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
Weakness
CWE-172
Updated
2026-11-02
EUVDEUVD-2025-5324 7.9

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Record
EUVD-2025-5324
CVSS 4.0
7.9 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
Updated
2026-11-02
NVD 7.9

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Record
CVE-2025-27110
CVSS 4.0
7.9 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-172
Updated
2026-11-02
OSV 7.9

Libmodsecurity3 has possible bypass of encoded HTML entities

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Record
CVE-2025-27110
CVSS 4.0
7.9 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
Weakness
CWE-172
Updated
2026-11-02
OSVDEBIAN-CVE-2025-27110 7.5

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Record
DEBIAN-CVE-2025-27110
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2025-27110 7.9

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Record
UBUNTU-CVE-2025-27110
CVSS 4.0
7.9 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVBIT-modsecurity-2025-27110 No score

Libmodsecurity3 has possible bypass of encoded HTML entities

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Record
BIT-modsecurity-2025-27110
Updated
2026-11-02
OSVBIT-modsecurity2-2025-27110 No score

Libmodsecurity3 has possible bypass of encoded HTML entities

Libmodsecurity is one component of the ModSecurity v3 project. The library codebase serves as an interface to ModSecurity Connectors taking in web traffic and applying traditional ModSecurity processing. A bug that exists only in Libmodsecurity3 version 3.0.13 means that, in 3.0.13, Libmodsecurity3 can't decode encoded HTML entities if they contains leading zeroes. Version 3.0.14 contains a fix. No known workarounds are available.

Record
BIT-modsecurity2-2025-27110
Updated
2026-11-02
OSVopenSUSE-SU-2025:14946-1 No score

libmodsecurity3-3.0.14-1.1 on GA media

These are all security issues fixed in the libmodsecurity3-3.0.14-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14946-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
modsecurity
Bitnami
3.0.13 up to 3.0.14
3.0.14
modsecurity2
Bitnami
3.0.13 and later None known
modsecurity
Debian:13
before 3.0.14-1
3.0.14-1
modsecurity
Debian:14
before 3.0.14-1
3.0.14-1
modsecurity
Ubuntu:20.04:LTS
All versions, plus listed versions
3.0.3-13.0.4-13.0.4-1build1
None known
modsecurity
Ubuntu:22.04:LTS
All versions, plus listed versions
3.0.4-23.0.6-1
None known
modsecurity
Ubuntu:24.04:LTS
All versions, plus listed versions
3.0.10-13.0.11-13.0.12-13.0.12-1.1build13.0.12-1.1build2
None known
modsecurity
Ubuntu:25.10
All versions, plus listed versions
3.0.13-13.0.14-13.0.14-1build1
None known
modsecurity
Ubuntu:26.10
All versions, plus listed versions
3.0.14-1build23.0.15-13.0.16-1
None known
modsecurity
Ubuntu:26.04:LTS
All versions, plus listed versions
3.0.14-1build13.0.14-1build2
None known
modsecurity
openSUSE:Tumbleweed
before 3.0.14-1.1
3.0.14-1.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-27110 is a high vulnerability (CVSS 7.9) in Owasp-modsecurity Modsecurity, published February 25, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 42nd percentile. Fixed in modsecurity 3.0.14.

References

MoveEnter Open