CVE-2025-27598
Out-of-bounds Write in SixLabors ImageSharp
ImageSharp is a 2D graphics API. An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service. The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Out-of-bounds Write in SixLabors ImageSharp
ImageSharp is a 2D graphics API. An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service. The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.
- Record
CVE-2025-27598- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2025-6253
7.5
ImageSharp is a 2D graphics API. An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service. The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.
- Record
EUVD-2025-6253- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-2cmq-823j-5qj8
7.5
Out-of-bounds Write in SixLabors ImageSharp
Impact
An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service.
Patches
The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.
Workarounds
None.
References
https://github.com/SixLabors/ImageSharp/issues/2859 https://github.com/SixLabors/ImageSharp/issues/2890
- Record
GHSA-2cmq-823j-5qj8- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
NVD
7.5
ImageSharp is a 2D graphics API. An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service. The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.
- Record
CVE-2025-27598- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
7.5
Out-of-bounds Write in SixLabors ImageSharp
ImageSharp is a 2D graphics API. An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service. The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.
- Record
CVE-2025-27598- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVGHSA-2cmq-823j-5qj8
7.5
Out-of-bounds Write in SixLabors ImageSharp
Impact
An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service.
Patches
The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.
Workarounds
None.
References
https://github.com/SixLabors/ImageSharp/issues/2859 https://github.com/SixLabors/ImageSharp/issues/2890
- Record
GHSA-2cmq-823j-5qj8- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
SixLabors.ImageSharpNuGet |
3.0.0 up to 3.1.7 | 3.1.7 |
SixLabors.ImageSharpNuGet |
before 2.1.10 | 2.1.10 |
SixLabors.ImageSharpNuGet |
3.0.0 up to 3.1.7, plus listed versions 3.0.13.0.23.1.03.1.13.1.2 Show 4 moreShow less3.1.33.1.43.1.53.1.6 |
3.1.7 |
SixLabors.ImageSharpNuGet |
before 2.1.10, plus listed versions 1.0.01.0.0-beta00011.0.0-beta00021.0.0-beta00031.0.0-beta0004 Show 21 moreShow less1.0.0-beta00051.0.0-beta00061.0.0-beta00071.0.0-rc00011.0.0-rc00021.0.0-rc00031.0.11.0.21.0.31.0.42.0.02.1.02.1.12.1.22.1.32.1.42.1.52.1.62.1.72.1.82.1.9 |
2.1.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-27598 is a high vulnerability (CVSS 7.5) in Sixlabors Imagesharp, published March 6, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in SixLabors.ImageSharp 3.1.7.
References
github.com/SixLabors/ImageSharp/security/advisories/GHSA-2cmq-823j-5qj8
github.com/SixLabors/ImageSharp/issues/2859
github.com/SixLabors/ImageSharp/pull/2890
nvd.nist.gov/vuln/detail/CVE-2025-27598
github.com/advisories/GHSA-2cmq-823j-5qj8
github.com/CVEProject/cvelistV5/tree/main/cves/2025/27xxx/CVE-2025-27598.json
github.com/SixLabors/ImageSharp