Every CVE Search/ Get API key

CVE-2025-27821

HDFS native client: Out of bounds write in URI parser of native HDFS client

7.3 HighFix available

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.91%Up 0.9 points since Jan 26, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.3

HDFS native client: Out of bounds write in URI parser of native HDFS client

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Record
CVE-2025-27821
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02
EUVDEUVD-2025-206351 7.3

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Record
EUVD-2025-206351
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-92cc-952p-v8rh 7.3

Apache Hadoop HDFS Native Client has Out-of-bounds Write Vulnerability

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Record
GHSA-92cc-952p-v8rh
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02
NVD 7.3

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Record
CVE-2025-27821
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02
OSV 7.3

HDFS native client: Out of bounds write in URI parser of native HDFS client

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Record
CVE-2025-27821
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02
OSVGHSA-92cc-952p-v8rh 7.3

Apache Hadoop HDFS Native Client has Out-of-bounds Write Vulnerability

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Record
GHSA-92cc-952p-v8rh
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.hadoop:hadoop-hdfs-native-client
Maven
3.2.0 up to 3.4.2
3.4.2
org.apache.hadoop:hadoop-hdfs-native-client
Maven
3.2.0 up to 3.4.2, plus listed versions
3.2.13.2.23.2.33.2.43.3.0
Show 8 moreShow less
3.3.13.3.23.3.33.3.43.3.53.3.63.4.03.4.1
3.4.2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-27821 is a high vulnerability (CVSS 7.3) in Apache Hadoop, published January 26, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.91%, the 60th percentile. Fixed in org.apache.hadoop:hadoop-hdfs-native-client 3.4.2.

References

Show 4 moreShow less
MoveEnter Open