CVE-2025-2814
Crypt::CBC versions between 1.21 and 3.05 for Perl may use insecure rand() function for cryptographic functions
Crypt::CBC versions between 1.21 and 3.05 for Perl may use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions.
This issue affects operating systems where "/dev/urandom'" is unavailable. In that case, Crypt::CBC will fallback to use the insecure rand() function.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.0
Crypt::CBC versions between 1.21 and 3.05 for Perl may use insecure rand() function for cryptographic functions
Crypt::CBC versions between 1.21 and 3.05 for Perl may use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions.
This issue affects operating systems where "/dev/urandom'" is unavailable. In that case, Crypt::CBC will fallback to use the insecure rand() function.
- Record
CVE-2025-2814- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-338, CWE-329, CWE-331, CWE-338
- Updated
- 2026-11-02
EUVDEUVD-2025-10846
4.0
Crypt::CBC versions between 1.21 and 3.05 for Perl may use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions.
This issue affects operating systems where "/dev/urandom'" is unavailable. In that case, Crypt::CBC will fallback to use the insecure rand() function.
- Record
EUVD-2025-10846- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-xpfq-7j72-x4px
4.0
Crypt::CBC versions between 1.21 and 3.04 for Perl may use the rand() function as the default...
Crypt::CBC versions between 1.21 and 3.04 for Perl may use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions.
This issue affects operating systems where "/dev/urandom'" is unavailable. In that case, Crypt::CBC will fallback to use the insecure rand() function.
- Record
GHSA-xpfq-7j72-x4px- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-329, CWE-338
- Updated
- 2026-11-02
NVD
4.0
Crypt::CBC versions between 1.21 and 3.05 for Perl may use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions.
This issue affects operating systems where "/dev/urandom'" is unavailable. In that case, Crypt::CBC will fallback to use the insecure rand() function.
- Record
CVE-2025-2814- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-329, CWE-331, CWE-338
- Updated
- 2026-11-02
OSV
4.0
Crypt::CBC versions between 1.21 and 3.05 for Perl may use insecure rand() function for cryptographic functions
Crypt::CBC versions between 1.21 and 3.05 for Perl may use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions.
This issue affects operating systems where "/dev/urandom'" is unavailable. In that case, Crypt::CBC will fallback to use the insecure rand() function.
- Record
CVE-2025-2814- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-329, CWE-331, CWE-338
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-2814
4.0
Crypt::CBC versions between 1.21 and 3.05 for Perl may use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions. This issue affects operating systems where "/dev/urandom'" is unavailable. In that case, Crypt::CBC will fallback to use the insecure rand() function.
- Record
DEBIAN-CVE-2025-2814- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-2814
4.0
Crypt::CBC versions between 1.21 and 3.05 for Perl may use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions. This issue affects operating systems where "/dev/urandom'" is unavailable. In that case, Crypt::CBC will fallback to use the insecure rand() function.
- Record
UBUNTU-CVE-2025-2814- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVopenSUSE-SU-2025:15495-1 No score
perl-Crypt-CBC-3.70.0-1.1 on GA media
These are all security issues fixed in the perl-Crypt-CBC-3.70.0-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:15495-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libcrypt-cbc-perlDebian:12 |
All versions, plus listed versions 3.04-33.07-1 |
None known |
libcrypt-cbc-perlDebian:13 |
All versions, plus listed versions 3.04-33.07-1 |
None known |
libcrypt-cbc-perlDebian:14 |
before 3.07-1, plus listed versions 3.04-3 |
3.07-1 |
libcrypt-cbc-perlUbuntu:16.04:LTS |
All versions, plus listed versions 2.33-1 |
None known |
libcrypt-cbc-perlUbuntu:18.04:LTS |
All versions, plus listed versions 2.33-1 |
None known |
libcrypt-cbc-perlUbuntu:20.04:LTS |
All versions, plus listed versions 2.33-2 |
None known |
libcrypt-cbc-perlUbuntu:22.04:LTS |
All versions, plus listed versions 2.33-23.04-3 |
None known |
libcrypt-cbc-perlUbuntu:24.04:LTS |
All versions, plus listed versions 3.04-3 |
None known |
libcrypt-cbc-perlUbuntu:25.10 |
All versions, plus listed versions 3.04-33.07-1 |
None known |
libcrypt-cbc-perlUbuntu:26.10 |
All versions, plus listed versions 3.07-1 |
None known |
libcrypt-cbc-perlUbuntu:26.04:LTS |
All versions, plus listed versions 3.07-1 |
None known |
perl-Crypt-CBCopenSUSE:Tumbleweed |
before 3.70.0-1.1 | 3.70.0-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-2814 is a medium vulnerability (CVSS 4.0) in Lds Crypt::cbc, published April 12, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.20%, the 10th percentile. Fixed in libcrypt-cbc-perl 3.07-1.
References
perldoc.perl.org/functions/rand
metacpan.org/dist/Crypt-CBC/source/lib/Crypt/CBC.pm
security.metacpan.org/docs/guides/random-data-for-security.html
github.com/lstein/Lib-Crypt-CBC/commit/37111f7cd894bcec46156ba7f40a49c126ebf535.patch
nvd.nist.gov/vuln/detail/CVE-2025-2814
github.com/advisories/GHSA-xpfq-7j72-x4px
Show 8 moreShow less
cpan.org/modules
github.com/CVEProject/cvelistV5/tree/main/cves/2025/2xxx/CVE-2025-2814.json
github.com/lstein/Lib-Crypt-CBC
security-tracker.debian.org/tracker/CVE-2025-2814
ubuntu.com/security/CVE-2025-2814
cve.org/CVERecord?id=CVE-2025-2814
lists.security.metacpan.org/cve-announce/msg/28699380
suse.com/security/cve/CVE-2025-2814