CVE-2025-30093
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before...
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.1
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.
- Record
CVE-2025-30093- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
EUVDEUVD-2025-8518
8.1
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.
- Record
EUVD-2025-8518- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-v64g-gxm8-whwj
8.1
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before...
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.
- Record
GHSA-v64g-gxm8-whwj- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
NVD
8.1
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.
- Record
CVE-2025-30093- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
OSV
8.1
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.
- Record
CVE-2025-30093- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-30093
8.1
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.
- Record
DEBIAN-CVE-2025-30093- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-30093
8.1
HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.
- Record
UBUNTU-CVE-2025-30093- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
condorDebian:13 |
before 23.9.6+dfsg-2 | 23.9.6+dfsg-2 |
condorDebian:14 |
before 23.9.6+dfsg-2 | 23.9.6+dfsg-2 |
condorUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 7.8.8~dfsg.1-27.8.8~dfsg.1-2.18.0.5~dfsg.1-1ubuntu18.0.5~dfsg.1-1ubuntu1+esm1 |
None known |
condorUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 8.2.9~dfsg.1-18.4.2~dfsg.1-18.4.2~dfsg.1-1build18.4.2~dfsg.1-1ubuntu0.1~esm1 |
None known |
condorUbuntu:18.04:LTS |
All versions, plus listed versions 8.4.11~dfsg.1-28.4.11~dfsg.1-38.6.8~dfsg.1-18.6.8~dfsg.1-2 |
None known |
condorUbuntu:20.04:LTS |
All versions, plus listed versions 8.6.8~dfsg.1-2build18.6.8~dfsg.1-2ubuntu1 |
None known |
condorUbuntu:24.04:LTS |
All versions, plus listed versions 23.2.0+dfsg-123.2.0+dfsg-223.4.0+dfsg-123.4.0+dfsg-1ubuntu223.4.0+dfsg-1ubuntu323.4.0+dfsg-1ubuntu423.4.0+dfsg-1ubuntu4.1 |
None known |
condorUbuntu:25.10 |
All versions, plus listed versions 23.6.2+dfsg-2build123.9.6+dfsg-223.9.6+dfsg-2build123.9.6+dfsg-2.123.9.6+dfsg-2.1build2 |
None known |
condorUbuntu:26.10 |
All versions, plus listed versions 25.6.1+dfsg-125.8.2+dfsg-125.10.1+dfsg-125.10.1+dfsg-225.11.0+dfsg-125.12.2+dfsg-1 |
None known |
condorUbuntu:26.04:LTS |
All versions, plus listed versions 23.9.6+dfsg-2.1build225.6.1+dfsg-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-30093 is a high vulnerability (CVSS 8.1) in Wisc Htcondor, published March 27, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 29th percentile. Fixed in condor 23.9.6+dfsg-2.
References
htcondor.org/security/vulnerabilities/HTCONDOR-2025-0001.html
nvd.nist.gov/vuln/detail/CVE-2025-30093
github.com/advisories/GHSA-v64g-gxm8-whwj
github.com/CVEProject/cvelistV5/tree/main/cves/2025/30xxx/CVE-2025-30093.json
security-tracker.debian.org/tracker/CVE-2025-30093
ubuntu.com/security/CVE-2025-30093
cve.org/CVERecord?id=CVE-2025-30093