CVE-2025-30145
GeoServer has an Infinite Loop Vulnerability in Jiffle process
GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
GeoServer has an Infinite Loop Vulnerability in Jiffle process
GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.
- Record
CVE-2025-30145- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-835
- Updated
- 2026-11-02
EUVDEUVD-2025-17684
7.5
GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.
- Record
EUVD-2025-17684- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-gr67-pwcv-76gf
7.5
GeoServer Infinite Loop Vulnerability in Jiffle process
Summary
Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service.
Details
The Jiffle language supports multiple loop constructs that will cause its code block to be continuously executed until a certain condition is met. The Jiffle runtime should be updated to throw an exception if the script exceeds a certain number of loop iterations.
Impact
This vulnerability allows attackers to conduct denial-of-service attacks.
Mitigation
This vulnerability can be mitigated by disabling WMS dynamic styling (see WMS Settings). If the WPS extension is installed, the Jiffle process must also be disabled to mitigate this vulnerability (see WPS Settings)
References
https://github.com/geosolutions-it/jai-ext/pull/307 https://osgeo-org.atlassian.net/browse/GEOS-11778
- Record
GHSA-gr67-pwcv-76gf- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-835
- Updated
- 2026-11-02
NVD
7.5
GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.
- Record
CVE-2025-30145- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-835
- Updated
- 2026-11-02
OSV
7.5
GeoServer has an Infinite Loop Vulnerability in Jiffle process
GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.
- Record
CVE-2025-30145- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-835
- Updated
- 2026-11-02
OSVGHSA-gr67-pwcv-76gf
7.5
GeoServer Infinite Loop Vulnerability in Jiffle process
Summary
Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service.
Details
The Jiffle language supports multiple loop constructs that will cause its code block to be continuously executed until a certain condition is met. The Jiffle runtime should be updated to throw an exception if the script exceeds a certain number of loop iterations.
Impact
This vulnerability allows attackers to conduct denial-of-service attacks.
Mitigation
This vulnerability can be mitigated by disabling WMS dynamic styling (see WMS Settings). If the WPS extension is installed, the Jiffle process must also be disabled to mitigate this vulnerability (see WPS Settings)
References
https://github.com/geosolutions-it/jai-ext/pull/307 https://osgeo-org.atlassian.net/browse/GEOS-11778
- Record
GHSA-gr67-pwcv-76gf- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-835
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.geoserver.web:gs-web-appMaven |
2.26.0 to 2.26.2 | 2.26.3 |
org.geoserver:gs-wmsMaven |
2.26.0 to 2.26.2 | 2.26.3 |
org.geoserver.extension:gs-wps-coreMaven |
2.26.0 to 2.26.2 | 2.26.3 |
org.geoserver.web:gs-web-appMaven |
through 2.25.6 | 2.25.7 |
org.geoserver:gs-wmsMaven |
through 2.25.6 | 2.25.7 |
org.geoserver.extension:gs-wps-coreMaven |
through 2.25.6 | 2.25.7 |
org.geoserver.web:gs-web-appMaven |
2.26.0 up to 2.26.3 | 2.26.3 |
org.geoserver:gs-wmsMaven |
2.26.0 up to 2.26.3 | 2.26.3 |
org.geoserver.extension:gs-wps-coreMaven |
2.26.0 up to 2.26.3 | 2.26.3 |
org.geoserver.web:gs-web-appMaven |
before 2.25.7 | 2.25.7 |
org.geoserver:gs-wmsMaven |
before 2.25.7 | 2.25.7 |
org.geoserver.extension:gs-wps-coreMaven |
before 2.25.7 | 2.25.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-30145 is a high vulnerability (CVSS 7.5) in Geoserver, published June 10, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in org.geoserver.web:gs-web-app 2.26.3.
References
github.com/geoserver/geoserver/security/advisories/GHSA-gr67-pwcv-76gf
github.com/geosolutions-it/jai-ext/pull/307
osgeo-org.atlassian.net/browse/GEOS-11778
nvd.nist.gov/vuln/detail/CVE-2025-30145
github.com/advisories/GHSA-gr67-pwcv-76gf
github.com/CVEProject/cvelistV5/tree/main/cves/2025/30xxx/CVE-2025-30145.json
github.com/geoserver/geoserver