Every CVE Search/ Get API key

CVE-2025-30212

Frappe has possibility of SQL injection due to improper validations

6.6 MediumFix available

Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.44%Up 0.4 points since Mar 26, 2025
90%50%10%1%

What each source reports

CVE List Score used 6.6

Frappe has possibility of SQL injection due to improper validations

Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.

Record
CVE-2025-30212
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Weakness
CWE-89
Updated
2026-11-02
EUVDEUVD-2025-8082 6.6

Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.

Record
EUVD-2025-8082
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Updated
2026-11-02
GitHub AdvisoriesGHSA-3hj6-r5c9-q8f3 6.6

Frappe has possibility of SQL injection due to improper validations

Impact

An SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information.

Workarounds

Upgrading is required, no other workaround is present.

Credits

Thanks to Thanh of Calif.io for reporting the issue

Record
GHSA-3hj6-r5c9-q8f3
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Weakness
CWE-89
Updated
2026-11-02
NVD 6.6

Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.

Record
CVE-2025-30212
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-89
Updated
2026-11-02
OSV 6.6

Frappe has possibility of SQL injection due to improper validations

Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.

Record
CVE-2025-30212
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Weakness
CWE-89
Updated
2026-11-02
OSVGHSA-3hj6-r5c9-q8f3 6.6

Frappe has possibility of SQL injection due to improper validations

Impact

An SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information.

Workarounds

Upgrading is required, no other workaround is present.

Credits

Thanks to Thanh of Calif.io for reporting the issue

Record
GHSA-3hj6-r5c9-q8f3
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Weakness
CWE-89
Updated
2026-11-02
OSVPYSEC-2026-1390 6.6

Frappe has possibility of SQL injection due to improper validations

Impact

An SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information.

Workarounds

Upgrading is required, no other workaround is present.

Credits

Thanks to Thanh of Calif.io for reporting the issue

Record
PYSEC-2026-1390
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
frappe
PyPI
before 14.89.0
14.89.0
frappe
PyPI
15.0.0 up to 15.51.0
15.51.0
frappe
PyPI
before 14.89.0, plus listed versions
0.0.1
14.89.0
frappe
PyPI
before 14.89.0, 15.0.0 up to 15.51.0, plus listed versions
0.0.1
14.89.015.51.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-30212 is a medium vulnerability (CVSS 6.6) in Elated-themes Frappe, published March 25, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in frappe 14.89.0.

References

MoveEnter Open