Every CVE Search/ Get API key

CVE-2025-30213

Frappe has Possibility of Remote Code Execution due to improper validation

6.3 MediumFix available

Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.72%Up 0.4 points since Mar 26, 2025
90%50%10%1%

What each source reports

CVE List Score used 6.3

Frappe has Possibility of Remote Code Execution due to improper validation

Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

Record
CVE-2025-30213
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2025-8081 6.3

Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

Record
EUVD-2025-8081
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Updated
2026-11-02
GitHub AdvisoriesGHSA-v342-4xr9-x3q3 6.3

Frappe has Possibility of Remote Code Execution due to improper validation

Impact

A system user was able to create certain documents in a specific way that could lead to RCE.

Workarounds

There's no workaround, an upgrade is required.

Credits

Thanks to Thanh of Calif.io for reporting the issue

Record
GHSA-v342-4xr9-x3q3
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-20
Updated
2026-11-02
NVD 6.3

Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

Record
CVE-2025-30213
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 6.3

Frappe has Possibility of Remote Code Execution due to improper validation

Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

Record
CVE-2025-30213
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-v342-4xr9-x3q3 6.3

Frappe has Possibility of Remote Code Execution due to improper validation

Impact

A system user was able to create certain documents in a specific way that could lead to RCE.

Workarounds

There's no workaround, an upgrade is required.

Credits

Thanks to Thanh of Calif.io for reporting the issue

Record
GHSA-v342-4xr9-x3q3
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-20
Updated
2026-11-02
OSVPYSEC-2026-1393 6.3

Frappe has Possibility of Remote Code Execution due to improper validation

Impact

A system user was able to create certain documents in a specific way that could lead to RCE.

Workarounds

There's no workaround, an upgrade is required.

Credits

Thanks to Thanh of Calif.io for reporting the issue

Record
PYSEC-2026-1393
CVSS 4.0
6.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
frappe
PyPI
before 14.91.0
14.91.0
frappe
PyPI
15.0.0 up to 15.52.0
15.52.0
frappe
PyPI
before 14.91.0, plus listed versions
0.0.1
14.91.0
frappe
PyPI
before 14.91.0, 15.0.0 up to 15.52.0, plus listed versions
0.0.1
14.91.015.52.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-30213 is a medium vulnerability (CVSS 6.3) in Elated-themes Frappe, published March 25, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.72%, the 54th percentile. Fixed in frappe 14.91.0.

References

MoveEnter Open