Every CVE Search/ Get API key

CVE-2025-30349

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS...

7.2 HighPublic exploitFix available

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS that leads to account takeover via a crafted text/html e-mail message with an onerror attribute (that may use base64-encoded JavaScript code), as exploited in the wild in March 2025.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

31.3%Up 31.2 points since Mar 22, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.2

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS that leads to account takeover via a crafted text/html e-mail message with an onerror attribute (that may use base64-encoded JavaScript code), as exploited in the wild in March 2025.

Record
CVE-2025-30349
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2025-7227 7.2

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS that leads to account takeover via a crafted text/html e-mail message with an onerror attribute (that may use base64-encoded JavaScript code), as exploited in the wild in March 2025.

Record
EUVD-2025-7227
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-mchq-vv84-m9gr 7.2

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS...

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS that leads to account takeover via a crafted text/html e-mail message with an onerror attribute (that may use base64-encoded JavaScript code), as exploited in the wild in March 2025.

Record
GHSA-mchq-vv84-m9gr
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 7.2

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS that leads to account takeover via a crafted text/html e-mail message with an onerror attribute (that may use base64-encoded JavaScript code), as exploited in the wild in March 2025.

Record
CVE-2025-30349
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 7.2

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS that leads to account takeover via a crafted text/html e-mail message with an onerror attribute (that may use base64-encoded JavaScript code), as exploited in the wild in March 2025.

Record
CVE-2025-30349
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVDEBIAN-CVE-2025-30349 7.2

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS that leads to account takeover via a crafted text/html e-mail message with an onerror attribute (that may use base64-encoded JavaScript code), as exploited in the wild in March 2025.

Record
DEBIAN-CVE-2025-30349
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2025-30349 7.2

Horde IMP through 6.2.27, as used with Horde Application Framework through 5.2.23, allows XSS that leads to account takeover via a crafted text/html e-mail message with an onerror attribute (that may use base64-encoded JavaScript code), as exploited in the wild in March 2025.

Record
UBUNTU-CVE-2025-30349
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php-horde-imp
Debian:12
All versions, plus listed versions
6.2.27-36.2.27-3.1
None known
php-horde-imp
Debian:11
before 6.2.27-2+deb11u1, plus listed versions
6.2.27-2
6.2.27-2+deb11u1
php-horde
Ubuntu:16.04:LTS
All versions, plus listed versions
5.2.7+debian0-15.2.8+debian0-15.2.9+debian0-15.2.9+debian0-1build1
None known
php-horde-imp
Ubuntu:16.04:LTS
All versions, plus listed versions
6.2.10-16.2.11-16.2.12-16.2.12-1ubuntu1
None known
php-horde
Ubuntu:18.04:LTS
All versions, plus listed versions
5.2.16+debian0-15.2.17+debian0-1
None known
php-horde-imp
Ubuntu:18.04:LTS
All versions, plus listed versions
6.2.20-16.2.21-16.2.21-1ubuntu1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubnatasaka/CVE-2025-303492025-03-27

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-30349 is a high vulnerability (CVSS 7.2) in Horde Imp, published March 21, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 31.3%, the 98th percentile. Fixed in php-horde-imp 6.2.27-2+deb11u1.

References

Show 14 moreShow less
MoveEnter Open