Every CVE Search/ Get API key

CVE-2025-31160

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and...

2.9 LowFix available

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.22%Up 0.2 points since Mar 27, 2025
90%50%10%1%

What each source reports

CVE List Score used 2.9

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
CVE-2025-31160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-617
Updated
2026-11-02
EUVDEUVD-2025-8259 2.9

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
EUVD-2025-8259
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-j37q-3xjr-5589 2.9

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and...

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
GHSA-j37q-3xjr-5589
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-617
Updated
2026-11-02
NVD 2.9

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
CVE-2025-31160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-617
Updated
2026-11-02
OSVALPINE-CVE-2025-31160 2.9

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
ALPINE-CVE-2025-31160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSV 2.9

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
CVE-2025-31160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-617
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2025-31160 2.9

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
DEBIAN-CVE-2025-31160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2025-31160 2.9

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
UBUNTU-CVE-2025-31160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVAZL-59270 No score

CVE-2025-31160 affecting package atop for versions less than 2.6.0-10

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
AZL-59270
Updated
2026-11-02
OSVAZL-59278 No score

CVE-2025-31160 affecting package atop for versions less than 2.9.0-2

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop.

Record
AZL-59278
Updated
2026-11-05
OSVMGASA-2025-0129 No score

Updated atop packages fix security vulnerability

atop through 2.11.0 allows local users to cause a denial of service (e.g., assertion failure and application exit) or possibly have unspecified other impact by running certain types of unprivileged processes while a different user runs atop. (CVE-2025-31160)

Record
MGASA-2025-0129
Updated
2026-11-02
OSVopenSUSE-SU-2025:14945-1 No score

atop-2.11.1-1.1 on GA media

These are all security issues fixed in the atop-2.11.1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14945-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
atop
Alpine:v3.21
before 2.11.1-r0
2.11.1-r0
atop
Alpine:v3.22
before 2.11.1-r0
2.11.1-r0
atop
Alpine:v3.23
before 2.11.1-r0
2.11.1-r0
atop
Alpine:v3.24
before 2.11.1-r0
2.11.1-r0
atop
Azure Linux:2
before 2.6.0-10
2.6.0-10
atop
Azure Linux:3
before 2.9.0-2
2.9.0-2
atop
Debian:12
before 2.8.1-1+deb12u1, plus listed versions
2.8.1-1
2.8.1-1+deb12u1
atop
Debian:13
before 2.11.1-1
2.11.1-1
atop
Debian:14
before 2.11.1-1
2.11.1-1
atop
Debian:11
before 2.6.0-2+deb11u1, plus listed versions
2.6.0-2
2.6.0-2+deb11u1
Show 11 moreShow less
Affected packages
PackageAffectedFixed
atop
Mageia:9
before 2.8.1-1.1.mga9
2.8.1-1.1.mga9
atop
Ubuntu:14.04:LTS
All versions, plus listed versions
1.26-2
None known
atop
Ubuntu:16.04:LTS
All versions, plus listed versions
1.26-21.26-2build1
None known
atop
Ubuntu:18.04:LTS
All versions, plus listed versions
2.2.6-42.2.6-52.3.0-1
None known
atop
Ubuntu:20.04:LTS
All versions, plus listed versions
2.4.0-3
None known
atop
Ubuntu:22.04:LTS
All versions, plus listed versions
2.6.0-2build12.7.1-1
None known
atop
Ubuntu:24.04:LTS
All versions, plus listed versions
2.9.0-1ubuntu12.10.0-22.10.0-2ubuntu12.10.0-2ubuntu2
None known
atop
Ubuntu:25.10
All versions, plus listed versions
2.10.0-32.11.1-12.11.1-22.11.1-3
None known
atop
Ubuntu:26.10
All versions, plus listed versions
2.12.1-12.13.0-1
None known
atop
Ubuntu:26.04:LTS
All versions, plus listed versions
2.11.1-32.12.1-1
None known
atop
openSUSE:Tumbleweed
before 2.11.1-1.1
2.11.1-1.1

History

History
RecordedChangedSources
factsOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-31160 is a low vulnerability (CVSS 2.9) in Atop Project Atop, published March 26, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.22%, the 12th percentile. Fixed in atop 2.11.1-r0.

References

Show 18 moreShow less
MoveEnter Open