CVE-2025-3129
Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-028
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.4.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.8
Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-028
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.4.
- Record
CVE-2025-3129- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-307
- Updated
- 2026-11-02
EUVDEUVD-2025-10980
4.8
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.4.
- Record
EUVD-2025-10980- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9qmr-4gv6-xmf3
4.8
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code...
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.4.
- Record
GHSA-9qmr-4gv6-xmf3- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-307
- Updated
- 2026-11-02
NVD
4.8
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.4.
- Record
CVE-2025-3129- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-307
- Updated
- 2026-11-02
OSV
4.8
Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-028
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.4.
- Record
CVE-2025-3129- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-307
- Updated
- 2026-11-02
OSVCLSA-2026-1788969961 No score
TuxCare security update for drupal/access_code (1 CVE)
TuxCare rebuilt drupal/access_code to address 1 CVE. Fixed in 7.1.1-p1+tuxcare.
- Record
CLSA-2026-1788969961- Updated
- 2026-11-02
OSVDRUPAL-CONTRIB-2025-028 No score
This module enables users to log in using a short access code instead of providing a username/password combination.
The module doesn't sufficiently protect against brute force attacks to guess a user's access code.
This vulnerability is mitigated by the fact that access code based logins are off by default and only enabled for accounts that enable it. Sites could mitigate the issue without updating by:
- disabling the access code login method for critical accounts
- monitor and prevent brute force attacks in other ways (for example, with a Web Application Firewall)
- Record
DRUPAL-CONTRIB-2025-028- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
drupal/access_codeTuxCare:Packagist |
7.1.1 up to 7.1.1-p1+tuxcare | 7.1.1-p1+tuxcare |
drupal/access_codePackagist:https://packages.drupal.org/8 |
before 2.0.4 | 2.0.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-3129 is a medium vulnerability (CVSS 4.8) in Access Code Project Code, published April 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.27%, the 20th percentile. Fixed in drupal/access_code 7.1.1-p1+tuxcare.