CVE-2025-31723
Jenkins Simple Queue Plugin Cross-Site Request Forgery (CSRF)
A cross-site request forgery (CSRF) vulnerability in Jenkins Simple Queue Plugin 1.4.6 and earlier allows attackers to change and reset the build queue order.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.3
A cross-site request forgery (CSRF) vulnerability in Jenkins Simple Queue Plugin 1.4.6 and earlier allows attackers to change and reset the build queue order.
- Record
CVE-2025-31723- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
EUVDEUVD-2025-9528
4.3
A cross-site request forgery (CSRF) vulnerability in Jenkins Simple Queue Plugin 1.4.6 and earlier allows attackers to change and reset the build queue order.
- Record
EUVD-2025-9528- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hcfh-qjcp-34q9
4.3
Jenkins Simple Queue Plugin Cross-Site Request Forgery (CSRF)
Jenkins Simple Queue Plugin 1.4.6 and earlier does not require POST requests for multiple HTTP endpoints, resulting in cross-site request forgery (CSRF) vulnerabilities.
These vulnerabilities allow attackers to change and reset the build queue order.
Simple Queue Plugin 1.4.7 requires POST requests for the affected HTTP endpoints.
Administrators can enable equivalent HTTP endpoints without CSRF protection via the global configuration.
- Record
GHSA-hcfh-qjcp-34q9- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
NVD
4.3
A cross-site request forgery (CSRF) vulnerability in Jenkins Simple Queue Plugin 1.4.6 and earlier allows attackers to change and reset the build queue order.
- Record
CVE-2025-31723- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVGHSA-hcfh-qjcp-34q9
4.3
Jenkins Simple Queue Plugin Cross-Site Request Forgery (CSRF)
Jenkins Simple Queue Plugin 1.4.6 and earlier does not require POST requests for multiple HTTP endpoints, resulting in cross-site request forgery (CSRF) vulnerabilities.
These vulnerabilities allow attackers to change and reset the build queue order.
Simple Queue Plugin 1.4.7 requires POST requests for the affected HTTP endpoints.
Administrators can enable equivalent HTTP endpoints without CSRF protection via the global configuration.
- Record
GHSA-hcfh-qjcp-34q9- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
io.jenkins.plugins:simple-queueMaven |
before 1.4.7 | 1.4.7 |
io.jenkins.plugins:simple-queueMaven |
before 1.4.7, plus listed versions 1.11.21.31.3.11.3.2 Show 8 moreShow less1.3.31.3.41.4.01.4.11.4.31.4.41.4.51.4.6 |
1.4.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-31723 is a medium vulnerability (CVSS 4.3) in Jenkins Simple Queue, published April 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in io.jenkins.plugins:simple-queue 1.4.7.