Every CVE Search/ Get API key

CVE-2025-31947

Repeated LDAP login failures can lock an LDAP account

5.8 MediumFix available

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to lockout LDAP users following repeated login failures, which allows attackers to lock external LDAP accounts through repeated login failures through Mattermost.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.35%Up 0.3 points since May 15, 2025
90%50%10%1%

What each source reports

CVE List Score used 5.8

Repeated LDAP login failures can lock an LDAP account

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to lockout LDAP users following repeated login failures, which allows attackers to lock external LDAP accounts through repeated login failures through Mattermost.

Record
CVE-2025-31947
CVSS 3.1
5.8 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Weakness
CWE-645
Updated
2026-11-02
EUVDEUVD-2025-15150 5.8

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to lockout LDAP users following repeated login failures, which allows attackers to lock external LDAP accounts through repeated login failures through Mattermost.

Record
EUVD-2025-15150
CVSS 3.1
5.8 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-qgwx-rffp-6cx9 5.8

Mattermost Fails to Lockout LDAP Users After Repeated Login Failures

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to lockout LDAP users following repeated login failures, which allows attackers to lock external LDAP accounts through repeated login failures through Mattermost.

Record
GHSA-qgwx-rffp-6cx9
CVSS 3.1
5.8 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Weakness
CWE-645
Updated
2026-11-02
NVD 5.8

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to lockout LDAP users following repeated login failures, which allows attackers to lock external LDAP accounts through repeated login failures through Mattermost.

Record
CVE-2025-31947
CVSS 3.1
5.8 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-645
Updated
2026-11-02
OSV 5.8

Repeated LDAP login failures can lock an LDAP account

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to lockout LDAP users following repeated login failures, which allows attackers to lock external LDAP accounts through repeated login failures through Mattermost.

Record
CVE-2025-31947
CVSS 3.1
5.8 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Weakness
CWE-645
Updated
2026-11-02
OSVGHSA-qgwx-rffp-6cx9 5.8

Mattermost Fails to Lockout LDAP Users After Repeated Login Failures

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to lockout LDAP users following repeated login failures, which allows attackers to lock external LDAP accounts through repeated login failures through Mattermost.

Record
GHSA-qgwx-rffp-6cx9
CVSS 3.1
5.8 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Weakness
CWE-645
Updated
2026-11-02
OSVGO-2025-3692 No score

Mattermost Fails to Lockout LDAP Users After Repeated Login Failures in github.com/mattermost/mattermost-server

Mattermost Fails to Lockout LDAP Users After Repeated Login Failures in github.com/mattermost/mattermost-server

Record
GO-2025-3692
Updated
2026-11-02
OSVopenSUSE-SU-2025:15159-1 No score

govulncheck-vulndb-0.0.20250523T151856-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250523T151856-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15159-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/mattermost/mattermost/server/v8
Go
10.6.0 to 10.6.1
10.6.2
github.com/mattermost/mattermost/server/v8
Go
10.5.0 to 10.5.2
10.5.3
github.com/mattermost/mattermost/server/v8
Go
10.4.0 to 10.4.4
10.4.5
github.com/mattermost/mattermost/server/v8
Go
9.11.0 to 9.11.11
9.11.12
github.com/mattermost/mattermost/server/v8
Go
before 8.0.0-20250415054241-76ab3867b785
8.0.0-20250415054241-76ab3867b785
github.com/mattermost/mattermost/server/v8
Go
10.6.0 up to 10.6.2
10.6.2
github.com/mattermost/mattermost/server/v8
Go
10.5.0 up to 10.5.3
10.5.3
github.com/mattermost/mattermost/server/v8
Go
10.4.0 up to 10.4.5
10.4.5
github.com/mattermost/mattermost/server/v8
Go
9.11.0 up to 9.11.12
9.11.12
github.com/mattermost/mattermost-server
Go
9.11.0+incompatible up to 9.11.12+incompatible, 10.4.0+incompatible up to 10.4.5+incompatible, 10.5.0+incompatible up to 10.5.3+incompatible, 10.6.0+incompatible up to 10.6.2+incompatible
9.11.12+incompatible10.4.5+incompatible10.5.3+incompatible10.6.2+incompatible
github.com/mattermost/mattermost-server/v5
Go
All versions None known
github.com/mattermost/mattermost-server/v6
Go
All versions None known
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 14 CVEs
before 0.0.20250523T151856-1.1
0.0.20250523T151856-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-31947 is a medium vulnerability (CVSS 5.8) in Mattermost, published May 15, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.35%, the 28th percentile. Fixed in github.com/mattermost/mattermost/server/v8 10.6.2.

References

Show 15 moreShow less
MoveEnter Open