Every CVE Search/ Get API key

CVE-2025-32027

Yii does not prevent XSS in scenarios where fallback error renderer is used

6.1 MediumFix available

CVE-2025-32027 is a medium vulnerability (CVSS 6.1) in Yiiframework Yii, published April 10, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.25%, the 16th percentile. Fixed in yiisoft/yii 1.1.31.

Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.25%Up 0.2 points since Apr 11, 2025
90%50%10%1%

What each source reports

CVE List Score used 6.1

Yii does not prevent XSS in scenarios where fallback error renderer is used

Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.

Record
CVE-2025-32027
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79, CWE-80
Updated
2026-11-02
EUVDEUVD-2025-10695 6.1

Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.

Record
EUVD-2025-10695
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-7r2v-8wxr-3ch5 6.1

Yii does not prevent XSS in scenarios where fallback error renderer is used

Impact

Affected versions of yiisoft/yii are vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used.

Patches

Upgrade yiisoft/yii to version 1.1.31 or higher.

References

If you have any questions or comments about this advisory, contact us through security form.

Record
GHSA-7r2v-8wxr-3ch5
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 6.1

Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.

Record
CVE-2025-32027
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79, CWE-80
Updated
2026-11-02
OSV 6.1

Yii does not prevent XSS in scenarios where fallback error renderer is used

Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.

Record
CVE-2025-32027
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79, CWE-80
Updated
2026-11-02
OSVGHSA-7r2v-8wxr-3ch5 6.1

Yii does not prevent XSS in scenarios where fallback error renderer is used

Impact

Affected versions of yiisoft/yii are vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used.

Patches

Upgrade yiisoft/yii to version 1.1.31 or higher.

References

If you have any questions or comments about this advisory, contact us through security form.

Record
GHSA-7r2v-8wxr-3ch5
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
yiisoft/yii
Packagist
before 1.1.31
1.1.31
yiisoft/yii
Packagist
before 1.1.31, plus listed versions
1.1.141.1.14-rc1.1.151.1.161.1.17
Show 13 moreShow less
1.1.181.1.191.1.201.1.211.1.221.1.231.1.241.1.251.1.261.1.271.1.281.1.291.1.30
1.1.31

History

History
WhenChangedSources
2026-11-02createdCVE List, EUVD, GitHub Advisories, NVD, OSV

References

MoveEnter Open