Every CVE Search/ Get API key

CVE-2025-3619

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a...

8.8 HighFix available

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.50%Up 0.4 points since Apr 17, 2025
90%50%10%1%

What each source reports

CVE List Score used 8.8

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
CVE-2025-3619
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-122, CWE-122
Updated
2026-11-02
EUVDEUVD-2025-11486 8.8

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
EUVD-2025-11486
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-qg97-xp64-p6pc 8.8

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a...

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
GHSA-qg97-xp64-p6pc
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-122
Updated
2026-11-02
NVD 8.8

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
CVE-2025-3619
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-122
Updated
2026-11-02
OSVALPINE-CVE-2025-3619 8.8

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
ALPINE-CVE-2025-3619
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
CVE-2025-3619
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2025-3619 8.8

Heap buffer overflow in Codecs in Google Chrome on Windows prior to 135.0.7049.95 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
DEBIAN-CVE-2025-3619
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2025-0140 No score

Updated chromium-browser-stable packages fix security vulnerabilities

Heap buffer overflow in Codecs. (CVE-2025-3619) Use after free in USB. (CVE-2025-3620)

Record
MGASA-2025-0140
Updated
2026-11-02
OSVopenSUSE-SU-2025:0133-1 No score

Security update for chromium

This update for chromium fixes the following issue:

chromium 135.0.7049.95 (stable release 2025-04-15) (boo#1241288):

  • CVE-2025-3619: Heap buffer overflow in Codecs
  • CVE-2025-3620: Use after free in USB
Record
openSUSE-SU-2025:0133-1
Updated
2026-11-02
OSVopenSUSE-SU-2025:15027-1 No score

chromedriver-135.0.7049.95-1.1 on GA media

These are all security issues fixed in the chromedriver-135.0.7049.95-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15027-1
Updated
2026-11-02
OSVopenSUSE-SU-2025:15531-1 No score

libQt5Pdf5-5.15.19-1.1 on GA media

These are all security issues fixed in the libQt5Pdf5-5.15.19-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15531-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qt5-qtwebengine
Alpine:v3.21
before 5.15.17-r7
5.15.17-r7
qt5-qtwebengine
Alpine:v3.22
before 5.15.17-r10
5.15.17-r10
qt5-qtwebengine
Alpine:v3.23
before 5.15.17-r10
5.15.17-r10
qt6-qtwebengine
Alpine:v3.22
before 6.8.2-r3
6.8.2-r3
qt6-qtwebengine
Alpine:v3.23
before 6.8.2-r3
6.8.2-r3
qt6-qtwebengine
Alpine:v3.24
before 6.8.2-r3
6.8.2-r3
chromium
Debian:12
before 135.0.7049.95-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
135.0.7049.95-1~deb12u1
chromium
Debian:13
before 135.0.7049.95-1
135.0.7049.95-1
chromium
Debian:14
before 135.0.7049.95-1
135.0.7049.95-1
chromium-browser-stable
Mageia:9
before 134.0.6998.165-2.mga9.tainted
134.0.6998.165-2.mga9.tainted
Show 4 moreShow less
Affected packages
PackageAffectedFixed
chromium
SUSE:Package Hub 15 SP6
before 135.0.7049.95-bp156.2.110.1
135.0.7049.95-bp156.2.110.1
chromium
openSUSE:Leap 15.6
before 135.0.7049.95-bp156.2.110.1
135.0.7049.95-bp156.2.110.1
chromium
openSUSE:Tumbleweed
before 135.0.7049.95-1.1
135.0.7049.95-1.1
libqt5-qtwebengine
openSUSE:Tumbleweed
before 5.15.19-1.1
5.15.19-1.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-3619 is a high vulnerability (CVSS 8.8) in Google Chrome, published April 16, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.50%, the 42nd percentile. Fixed in qt5-qtwebengine 5.15.17-r7.

References

Show 23 moreShow less
This page doesn't list everything

Left out here: 156 versions. The JSON record has them.

MoveEnter Open