CVE-2025-3638
Moodle: csrf risk in brickfield tool's analysis request action
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
Moodle: csrf risk in brickfield tool's analysis request action
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
- Record
CVE-2025-3638- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
EUVDEUVD-2025-12523
8.8
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
- Record
EUVD-2025-12523- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-m8qh-hx4c-h9hr
1.3
Moodle has a CSRF risk in Brickfield tool's analysis request action
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
- Record
GHSA-m8qh-hx4c-h9hr- CVSS 4.0
- 1.3 Low
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-352
- Updated
- 2026-11-02
NVD
8.8
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
- Record
CVE-2025-3638- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
8.8
Moodle: csrf risk in brickfield tool's analysis request action
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
- Record
CVE-2025-3638- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVGHSA-m8qh-hx4c-h9hr
1.3
Moodle has a CSRF risk in Brickfield tool's analysis request action
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
- Record
GHSA-m8qh-hx4c-h9hr- CVSS 4.0
- 1.3 Low
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-3638
8.8
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
- Record
UBUNTU-CVE-2025-3638- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-moodle-2025-3638 No score
Moodle: csrf risk in brickfield tool's analysis request action
A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.
- Record
BIT-moodle-2025-3638- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 4.1.18 | 4.1.18 |
moodle/moodlePackagist |
4.3.0-beta up to 4.3.12 | 4.3.12 |
moodle/moodlePackagist |
4.4.0-beta up to 4.4.8 | 4.4.8 |
moodle/moodlePackagist |
4.5.0-beta up to 4.5.4 | 4.5.4 |
moodleBitnami |
before 4.1.18, 4.3.0 up to 4.3.12, 4.4.0 up to 4.4.8, 4.5.0 up to 4.5.4 | 4.1.184.3.124.4.84.5.4 |
moodle/moodlePackagist |
before 4.1.18, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 45 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1 |
4.1.18 |
moodle/moodlePackagist |
4.3.0-beta up to 4.3.12, plus listed versions v4.3.0v4.3.0-betav4.3.0-rc1v4.3.0-rc2v4.3.1 Show 10 moreShow lessv4.3.10v4.3.11v4.3.2v4.3.3v4.3.4v4.3.5v4.3.6v4.3.7v4.3.8v4.3.9 |
4.3.12 |
moodle/moodlePackagist |
4.4.0-beta up to 4.4.8, plus listed versions v4.4.0v4.4.0-betav4.4.0-rc1v4.4.0-rc2v4.4.1 Show 6 moreShow lessv4.4.2v4.4.3v4.4.4v4.4.5v4.4.6v4.4.7 |
4.4.8 |
moodle/moodlePackagist |
4.5.0-beta up to 4.5.4, plus listed versions v4.5.0v4.5.0-betav4.5.0-rc1v4.5.0-rc2v4.5.1v4.5.2v4.5.3 |
4.5.4 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-3638 is a high vulnerability (CVSS 8.8) in Moodle, published April 25, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.30%, the 22nd percentile. Fixed in moodle/moodle 4.1.18.
References
Left out here: 300 versions. The JSON record has them.