Every CVE Search/ Get API key

CVE-2025-3644

Moodle: ajax section delete does not respect course_can_delete_section()

4.3 MediumFix available

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.33%Up 0.3 points since Apr 26, 2025
90%50%10%1%

What each source reports

CVE List Score used 4.3

Moodle: ajax section delete does not respect course_can_delete_section()

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Record
CVE-2025-3644
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2025-12517 4.3

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Record
EUVD-2025-12517
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-cpm7-mv33-jwf8 4.3

Moodle's AJAX section delete does not respect course_can_delete_section()

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Record
GHSA-cpm7-mv33-jwf8
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
NVD 4.3

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Record
CVE-2025-3644
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
OSV 4.3

Moodle: ajax section delete does not respect course_can_delete_section()

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Record
CVE-2025-3644
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
OSVGHSA-cpm7-mv33-jwf8 4.3

Moodle's AJAX section delete does not respect course_can_delete_section()

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Record
GHSA-cpm7-mv33-jwf8
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
OSVUBUNTU-CVE-2025-3644 4.3

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Record
UBUNTU-CVE-2025-3644
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVBIT-moodle-2025-3644 No score

Moodle: ajax section delete does not respect course_can_delete_section()

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Record
BIT-moodle-2025-3644
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 4.1.18
4.1.18
moodle/moodle
Packagist
4.3.0-beta up to 4.3.12
4.3.12
moodle/moodle
Packagist
4.4.0-beta up to 4.4.8
4.4.8
moodle/moodle
Packagist
4.5.0-beta up to 4.5.4
4.5.4
moodle
Bitnami
before 4.1.18, 4.3.0 up to 4.3.12, 4.4.0 up to 4.4.8, 4.5.0 up to 4.5.4
4.1.184.3.124.4.84.5.4
moodle/moodle
Packagist
before 4.1.18, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
4.1.18
moodle/moodle
Packagist
4.3.0-beta up to 4.3.12, plus listed versions
v4.3.0v4.3.0-betav4.3.0-rc1v4.3.0-rc2v4.3.1
Show 10 moreShow less
v4.3.10v4.3.11v4.3.2v4.3.3v4.3.4v4.3.5v4.3.6v4.3.7v4.3.8v4.3.9
4.3.12
moodle/moodle
Packagist
4.4.0-beta up to 4.4.8, plus listed versions
v4.4.0v4.4.0-betav4.4.0-rc1v4.4.0-rc2v4.4.1
Show 6 moreShow less
v4.4.2v4.4.3v4.4.4v4.4.5v4.4.6v4.4.7
4.4.8
moodle/moodle
Packagist
4.5.0-beta up to 4.5.4, plus listed versions
v4.5.0v4.5.0-betav4.5.0-rc1v4.5.0-rc2v4.5.1v4.5.2v4.5.3
4.5.4
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-3644 is a medium vulnerability (CVSS 4.3) in Moodle, published April 25, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in moodle/moodle 4.1.18.

References

Show 5 moreShow less
This page doesn't list everything

Left out here: 300 versions. The JSON record has them.

MoveEnter Open