CVE-2025-40913
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
CVE-2025-40913- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-1395
- Updated
- 2026-11-02
EUVDEUVD-2025-21701
6.5
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
EUVD-2025-21701- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x86q-3xjx-wg89
6.5
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an...
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
GHSA-x86q-3xjx-wg89- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
NVD
6.5
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
CVE-2025-40913- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
OSV
6.5
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
CVE-2025-40913- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-1395
- Updated
- 2026-11-02
OSVCVE-2025-40914
9.8
Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow
Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.
CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
CVE-2025-40914- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-1395
- Updated
- 2026-11-02
OSVAZL-65547 No score
CVE-2025-40913 affecting package libtommath 1.3.1~rc1-3
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
AZL-65547- Updated
- 2026-11-05
OSVAZL-65550 No score
CVE-2025-40913 affecting package samba 4.18.3-2
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
AZL-65550- Updated
- 2026-11-05
OSVAZL-65571 No score
CVE-2025-40913 affecting package tcl for versions less than 8.6.13-2
Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.
Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.
- Record
AZL-65571- Updated
- 2026-11-05
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libtommathAzure Linux:3 |
through 1.3.1~rc1-3 | None known |
sambaAzure Linux:3 |
through 4.18.3-2 | None known |
tclAzure Linux:3 |
before 8.6.13-2 | 8.6.13-2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-40913 is a medium vulnerability (CVSS 6.5) in Atrodo Net::dropbear, published June 11, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 25th percentile. Fixed in tcl 8.6.13-2.
References
cve.org/CVERecord?id=CVE-2023-36328
github.com/libtom/libtommath/pull/546
github.com/advisories/GHSA-j3xv-6967-cv88
metacpan.org/release/ATRODO/Net-Dropbear-0.16/source/dropbear/libtommath/bn_mp_grow.c
nvd.nist.gov/vuln/detail/CVE-2025-40913
github.com/advisories/GHSA-x86q-3xjx-wg89
Show 7 moreShow less
cpan.org/modules
github.com/CVEProject/cvelistV5/tree/main/cves/2025/40xxx/CVE-2025-40913.json
github.com/atrodo/Net-Dropbear
metacpan.org/release/MIK/CryptX-0.086/source/src/ltm/bn_mp_grow.c
github.com/CVEProject/cvelistV5/tree/main/cves/2025/40xxx/CVE-2025-40914.json
nvd.nist.gov/vuln/detail/CVE-2025-40914
github.com/DCIT/perl-CryptX