Every CVE Search/ Get API key

CVE-2025-40914

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow

9.8 CriticalFix available

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.

CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.54%Up 0.5 points since Jun 12, 2025
90%50%10%1%

What each source reports

CVE List Score used 9.8

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.

CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Record
CVE-2025-40914
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1395
Updated
2026-11-02
EUVDEUVD-2025-18120 9.8

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.

CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Record
EUVD-2025-18120
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
NVD 9.8

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.

CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Record
CVE-2025-40914
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVCVE-2025-40913 6.5

Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow

Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow.

Net::Dropbear embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Record
CVE-2025-40913
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-1395
Updated
2026-11-02
OSV 9.8

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.

CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Record
CVE-2025-40914
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1395
Updated
2026-11-02
OSVDEBIAN-CVE-2025-40914 9.8

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow. CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Record
DEBIAN-CVE-2025-40914
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2025-40914 9.8

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow. CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Record
UBUNTU-CVE-2025-40914
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVAZL-63927 No score

CVE-2025-40914 affecting package samba 4.18.3-2

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.

CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Record
AZL-63927
Updated
2026-11-05
OSVopenSUSE-SU-2025:15259-1 No score

perl-CryptX-0.87.0-1.1 on GA media

These are all security issues fixed in the perl-CryptX-0.87.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15259-1
Updated
2026-11-02
OSVUSN-8128-1 No score

libcryptx-perl vulnerabilities

It was discovered that CryptX did not verify authentication tags while performing GCM and ChaCha20-Poly1305 decryption. An attacker could possibly use this issue to cause CryptX to accept modified ciphertext, leading to data integrity violations or authentication bypass. This issue only affected Ubuntu 18.04 LTS. (CVE-2018-25099)

It was discovered that CryptX included a version of the tomcrypt library that was susceptible to malformed unicode handling. An attacker could possibly use this issue to cause unexpected behavior or incorrect processing of crafted input. This issue only affected Ubuntu 18.04 LTS. (CVE-2025-40912)

It was discovered that CryptX included a version of the libtommath library that was susceptible to an integer overflow. An attacker could possibly use this issue to cause memory corruption or a denial of service. (CVE-2025-40914)

Record
USN-8128-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
samba
Azure Linux:3
through 4.18.3-2 None known
libcryptx-perl
Debian:12
All versions, plus listed versions
0.077-10.078-10.080-10.080-20.081-1
Show 12 moreShow less
0.081-20.082-10.082.001-10.084-10.085-10.087-10.087-20.088-10.089-10.090-10.090-1~bpo13+10.091-1
None known
libcryptx-perl
Debian:13
All versions, plus listed versions
0.085-10.085-1+deb13u10.087-10.087-20.088-1
Show 4 moreShow less
0.089-10.090-10.090-1~bpo13+10.091-1
None known
libcryptx-perl
Debian:14
before 0.087-1, plus listed versions
0.085-1
0.087-1
libcryptx-perl
Ubuntu:Pro:18.04:LTS
before 0.056-1ubuntu0.1~esm1, plus listed versions
0.055-10.056-1
0.056-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:20.04:LTS
before 0.067-1ubuntu0.1~esm1, plus listed versions
0.064-10.064-1build10.066-10.067-1
0.067-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:22.04:LTS
before 0.076-1ubuntu0.1~esm1, plus listed versions
0.069-1build10.073-10.074-10.075-10.076-10.076-1build1
0.076-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:24.04:LTS
before 0.080-2ubuntu0.1~esm1, plus listed versions
0.078-10.080-10.080-20.080-2build10.080-2build20.080-2build3
0.080-2ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:18.04:LTS
From an advisory covering 3 CVEs
before 0.056-1ubuntu0.1~esm1, plus listed versions
0.055-10.056-1
0.056-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:20.04:LTS
From an advisory covering 3 CVEs
before 0.067-1ubuntu0.1~esm1, plus listed versions
0.064-10.064-1build10.066-10.067-1
0.067-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:22.04:LTS
From an advisory covering 3 CVEs
before 0.076-1ubuntu0.1~esm1, plus listed versions
0.069-1build10.073-10.074-10.075-10.076-10.076-1build1
0.076-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:24.04:LTS
From an advisory covering 3 CVEs
before 0.080-2ubuntu0.1~esm1, plus listed versions
0.078-10.080-10.080-20.080-2build10.080-2build20.080-2build3
0.080-2ubuntu0.1~esm1
perl-CryptX
openSUSE:Tumbleweed
before 0.87.0-1.1
0.87.0-1.1

History

History
RecordedChangedSources
affected
factsOSV
first indexedCVE List, EUVD, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-40914 is a critical vulnerability (CVSS 9.8) in Mik Cryptx, published June 11, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in libcryptx-perl 0.087-1.

References

Show 15 moreShow less
MoveEnter Open