CVE-2025-43929
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local...
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.1
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).
- Record
CVE-2025-43929- CVSS 3.1
- 4.1 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-346
- Updated
- 2026-11-02
EUVDEUVD-2025-14660
4.1
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).
- Record
EUVD-2025-14660- CVSS 3.1
- 4.1 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-cch3-2vm3-v73j
4.1
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local...
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).
- Record
GHSA-cch3-2vm3-v73j- CVSS 3.1
- 4.1 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-346
- Updated
- 2026-11-02
NVD
4.1
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).
- Record
CVE-2025-43929- CVSS 3.1
- 4.1 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-346
- Updated
- 2026-11-02
OSV
4.1
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).
- Record
CVE-2025-43929- CVSS 3.1
- 4.1 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-346
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-43929
7.8
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).
- Record
DEBIAN-CVE-2025-43929- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-43929
4.1
open_actions.py in kitty before 0.41.0 does not ask for user confirmation before running a local executable file that may have been linked from an untrusted document (e.g., a document opened in KDE ghostwriter).
- Record
UBUNTU-CVE-2025-43929- CVSS 3.1
- 4.1 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kittyDebian:12 |
All versions, plus listed versions 0.26.5-50.30.1-10.31.0-10.31.0-20.31.0-3 Show 34 moreShow less0.31.0-40.32.0-10.32.1-10.32.2-10.33.0-20.33.1-10.34.1-10.35.1-10.35.2-10.36.1-10.36.4-10.36.4-20.36.4-30.37.0-10.38.1-10.39.0-10.39.1-10.40.0-10.41.1-10.41.1-20.42.1-10.42.2-10.43.1-10.44.0-10.45.0-10.45.0-20.46.1-10.46.2-10.47.0-10.47.0-20.47.0-30.47.3-10.47.4-10.48.2-1 |
None known |
kittyDebian:13 |
before 0.41.1-1 | 0.41.1-1 |
kittyDebian:14 |
before 0.41.1-1 | 0.41.1-1 |
kittyUbuntu:24.04:LTS |
All versions, plus listed versions 0.26.5-3ubuntu20.26.5-5ubuntu10.31.0-30.31.0-40.32.2-1 Show 6 moreShow less0.32.2-1build20.32.2-1build30.32.2-1ubuntu0.10.32.2-1ubuntu0.20.32.2-1ubuntu0.30.32.2-1ubuntu0.4 |
None known |
kittyUbuntu:25.10 |
All versions, plus listed versions 0.39.1-10.41.1-20.41.1-2+deb13u1build0.25.10.1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | 0xBenCantCode/CVE-2025-43929 | 2025-04-20 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-43929 is a medium vulnerability (CVSS 4.1) in Kitty Project Kitty, published April 20, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.19%, the 8th percentile. Fixed in kitty 0.41.1-1.