Every CVE Search/ Get API key

CVE-2025-4638

Improper Pointer Arithmetic in pcl

9.2 CriticalFix available

A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.

Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
High
Availability
High

Exploit likelihood

0.55%Up 0.5 points since May 15, 2025
90%50%10%1%

What each source reports

CVE List Score used 9.2

Improper Pointer Arithmetic in pcl

A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.

Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.

Record
CVE-2025-4638
CVSS 4.0
9.2 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:L/SA:H/AU:Y/R:U/V:D/RE:M/U:Amber
Weakness
CWE-119
Updated
2026-11-02
EUVDEUVD-2025-14916 9.2

A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.

Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.

Record
EUVD-2025-14916
CVSS 4.0
9.2 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:L/SA:H/AU:Y/R:U/V:D/RE:M/U:Amber
Updated
2026-11-02
GitHub AdvisoriesGHSA-hg9g-m8wg-jv2x 9.2

A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within...

A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.

Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.

Record
GHSA-hg9g-m8wg-jv2x
CVSS 4.0
9.2 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:L/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:Y/R:U/V:D/RE:M/U:Amber
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
NVD 9.2

A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.

Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.

Record
CVE-2025-4638
CVSS 4.0
9.2 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:L/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:Y/R:U/V:D/RE:M/U:Amber
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.2

Improper Pointer Arithmetic in pcl

A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.

Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.

Record
CVE-2025-4638
CVSS 4.0
9.2 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:L/SA:H/AU:Y/R:U/V:D/RE:M/U:Amber
Updated
2026-11-02
OSVUBUNTU-CVE-2025-4638 9.2

A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic. Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.

Record
UBUNTU-CVE-2025-4638
CVSS 4.0
9.2 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:L/SA:H/AU:Y/R:U/V:D/RE:M/U:Amber
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2025-0162 No score

Updated zsync packages fix security vulnerabilities

Improper Pointer Arithmetic in pcl. (CVE-2025-4638)

Record
MGASA-2025-0162
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zsync
Mageia:9
before 0.6.2-11.1.mga9
0.6.2-11.1.mga9
pcl
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.7.2-10build11.7.2-131.7.2-14build11.7.2-14build1.11.7.2-14ubuntu0.11.7.2-14ubuntu0.1+esm1
None known
pcl
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
1.8.1+dfsg1-2ubuntu11.8.1+dfsg1-2ubuntu21.8.1+dfsg1-2ubuntu2.18.04.11.8.1+dfsg1-2ubuntu2.18.04.1+esm1
None known
pcl
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
1.9.1+dfsg1-10ubuntu21.9.1+dfsg1-10ubuntu31.10.0+dfsg-4ubuntu21.10.0+dfsg-5ubuntu11.10.0+dfsg-5ubuntu1+esm11.10.0+dfsg-5ubuntu1+esm2
None known
pcl
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1.11.1+dfsg-1build11.12.0+dfsg-5build11.12.0+dfsg-61.12.1+dfsg-31.12.1+dfsg-3build11.12.1+dfsg-3ubuntu0.1~esm11.12.1+dfsg-3ubuntu0.1~esm2
None known
pcl
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
1.13.0+dfsg-31.13.0+dfsg-3build11.13.0+dfsg-41.13.0+dfsg-4build21.13.0+dfsg-4build31.14.0+dfsg-11.14.0+dfsg-1ubuntu0.1~esm1
None known
pcl
Ubuntu:25.10
All versions, plus listed versions
1.14.0+dfsg-5ubuntu11.15.0+dfsg-21.15.0+dfsg-2build2
None known
pcl
Ubuntu:26.10
All versions, plus listed versions
1.15.1+dfsg-21.15.1+dfsg-31.15.1+dfsg-3build1
None known
pcl
Ubuntu:26.04:LTS
All versions, plus listed versions
1.15.0+dfsg-2build21.15.0+dfsg-31.15.1+dfsg-11.15.1+dfsg-2
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-4638 is a critical vulnerability (CVSS 9.2) in Pointcloudlibrary Pcl, published May 14, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.55%, the 46th percentile. Fixed in zsync 0.6.2-11.1.mga9.

References

Show 5 moreShow less
MoveEnter Open