CVE-2025-47229
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service ...
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service (var_set_leave_quiet assertion failure and application exit) via crafted input data, such as data that triggers a call from src/data/dictionary.c code into src/data/variable.c code.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
2.9
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service (var_set_leave_quiet assertion failure and application exit) via crafted input data, such as data that triggers a call from src/data/dictionary.c code into src/data/variable.c code.
- Record
CVE-2025-47229- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-617
- Updated
- 2026-11-02
EUVDEUVD-2025-13307
2.9
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service (var_set_leave_quiet assertion failure and application exit) via crafted input data, such as data that triggers a call from src/data/dictionary.c code into src/data/variable.c code.
- Record
EUVD-2025-13307- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-qwvr-9jqm-vrq5
2.9
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service ...
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service (var_set_leave_quiet assertion failure and application exit) via crafted input data, such as data that triggers a call from src/data/dictionary.c code into src/data/variable.c code.
- Record
GHSA-qwvr-9jqm-vrq5- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-617
- Updated
- 2026-11-02
NVD
2.9
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service (var_set_leave_quiet assertion failure and application exit) via crafted input data, such as data that triggers a call from src/data/dictionary.c code into src/data/variable.c code.
- Record
CVE-2025-47229- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-617
- Updated
- 2026-11-02
OSV
5.5
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service (var_set_leave_quiet assertion failure and application exit) via crafted input data, such as data that triggers a call from src/data/dictionary.c code into src/data/variable.c code.
- Record
CVE-2025-47229- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-47229
5.5
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service (var_set_leave_quiet assertion failure and application exit) via crafted input data, such as data that triggers a call from src/data/dictionary.c code into src/data/variable.c code.
- Record
DEBIAN-CVE-2025-47229- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-47229
2.9
libpspp-core.a in GNU PSPP through 2.0.1 allows attackers to cause a denial of service (var_set_leave_quiet assertion failure and application exit) via crafted input data, such as data that triggers a call from src/data/dictionary.c code into src/data/variable.c code.
- Record
UBUNTU-CVE-2025-47229- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
psppDebian:12 |
All versions, plus listed versions 1.6.2-22.0.0-12.0.0-22.0.0-32.0.1-12.1.0-12.1.1-12.1.2-1 |
None known |
psppDebian:13 |
All versions, plus listed versions 2.0.1-12.1.0-12.1.1-12.1.2-1 |
None known |
psppDebian:14 |
before 2.1.0-1, plus listed versions 2.0.1-1 |
2.1.0-1 |
psppUbuntu:16.04:LTS |
All versions, plus listed versions 0.8.5-40.8.5-4build10.8.5-50.8.5-5build1 |
None known |
psppUbuntu:18.04:LTS |
All versions, plus listed versions 1.0.1-1 |
None known |
psppUbuntu:22.04:LTS |
All versions, plus listed versions 1.4.1-11.4.1-1build1 |
None known |
psppUbuntu:24.04:LTS |
All versions, plus listed versions 1.6.2-22.0.0-32.0.0-3build12.0.0-3build2 |
None known |
psppUbuntu:25.10 |
All versions, plus listed versions 2.0.1-1build12.0.1-1build2 |
None known |
psppUbuntu:26.10 |
All versions, plus listed versions 2.0.1-1build3 |
None known |
psppUbuntu:26.04:LTS |
All versions, plus listed versions 2.0.1-1build22.0.1-1build3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-47229 is a low vulnerability (CVSS 2.9) in Gnu Pspp, published May 3, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.18%, the 8th percentile. Fixed in pspp 2.1.0-1.