Every CVE Search/ Get API key

CVE-2025-47283

Bypassing project secret validation can lead to privilege escalation

9.9 CriticalFix available

Gardener implements the automated management and operation of Kubernetes clusters as a service. A security vulnerability was discovered in Gardener prior to versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed. This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters. gardener/gardener (gardenlet) is the affected component. Versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 fix the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.68%Up 0.6 points since May 20, 2025
90%50%10%1%

What each source reports

CVE List Score used 9.9

Bypassing project secret validation can lead to privilege escalation

Gardener implements the automated management and operation of Kubernetes clusters as a service. A security vulnerability was discovered in Gardener prior to versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed. This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters. gardener/gardener (gardenlet) is the affected component. Versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 fix the issue.

Record
CVE-2025-47283
CVSS 3.0
9.9 CriticalCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2025-15799 9.9

Gardener implements the automated management and operation of Kubernetes clusters as a service. A security vulnerability was discovered in Gardener prior to versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed. This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters. gardener/gardener (gardenlet) is the affected component. Versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 fix the issue.

Record
EUVD-2025-15799
CVSS 3.0
9.9 CriticalCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-3hw7-qj9h-r835 9.9

Gardener allows bypassing project secret validation which can lead to privilege escalation

A security vulnerability was discovered in Gardener that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed.

Am I Vulnerable?

This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters.

Affected Components

  • gardener/gardener

Affected Versions

  • < v1.116.4
  • < v1.117.5
  • < v1.118.2
  • < v1.119.0

Fixed Versions

  • >= v1.116.4
  • >= v1.117.5
  • >= v1.118.2
  • >= v1.119.0

How do I mitigate this vulnerability?

Update to a fixed version.

Record
GHSA-3hw7-qj9h-r835
CVSS 3.0
9.9 CriticalCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-20, CWE-269
Updated
2026-11-02
NVD 9.9

Gardener implements the automated management and operation of Kubernetes clusters as a service. A security vulnerability was discovered in Gardener prior to versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed. This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters. gardener/gardener (gardenlet) is the affected component. Versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 fix the issue.

Record
CVE-2025-47283
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
CVSS 3.0
9.9 CriticalCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 9.9

Bypassing project secret validation can lead to privilege escalation

Gardener implements the automated management and operation of Kubernetes clusters as a service. A security vulnerability was discovered in Gardener prior to versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed. This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters. gardener/gardener (gardenlet) is the affected component. Versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 fix the issue.

Record
CVE-2025-47283
CVSS 3.0
9.9 CriticalCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-3hw7-qj9h-r835 9.9

Gardener allows bypassing project secret validation which can lead to privilege escalation

A security vulnerability was discovered in Gardener that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed.

Am I Vulnerable?

This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters.

Affected Components

  • gardener/gardener

Affected Versions

  • < v1.116.4
  • < v1.117.5
  • < v1.118.2
  • < v1.119.0

Fixed Versions

  • >= v1.116.4
  • >= v1.117.5
  • >= v1.118.2
  • >= v1.119.0

How do I mitigate this vulnerability?

Update to a fixed version.

Record
GHSA-3hw7-qj9h-r835
CVSS 3.0
9.9 CriticalCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-20, CWE-269
Updated
2026-11-02
OSVGO-2025-3696 No score

Gardener allows bypassing project secret validation which can lead to privilege escalation in github.com/gardener/gardener

Gardener allows bypassing project secret validation which can lead to privilege escalation in github.com/gardener/gardener

Record
GO-2025-3696
Updated
2026-11-02
OSVopenSUSE-SU-2025:15159-1 No score

govulncheck-vulndb-0.0.20250523T151856-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250523T151856-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15159-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/gardener/gardener
Go
before 1.116.4
1.116.4
github.com/gardener/gardener
Go
1.117.0 up to 1.117.5
1.117.5
github.com/gardener/gardener
Go
1.118.0 up to 1.118.2
1.118.2
github.com/gardener/gardener
Go
before 1.116.4, 1.117.0 up to 1.117.5, 1.118.0 up to 1.118.2
1.116.41.117.51.118.2
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 14 CVEs
before 0.0.20250523T151856-1.1
0.0.20250523T151856-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-47283 is a critical vulnerability (CVSS 9.9) in Gardener, published May 19, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in github.com/gardener/gardener 1.116.4.

References

Show 18 moreShow less
MoveEnter Open