CVE-2025-47944
Multer vulnerable to Denial of Service from maliciously crafted requests
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Multer vulnerable to Denial of Service from maliciously crafted requests
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
- Record
CVE-2025-47944- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
EUVDEUVD-2025-15796
7.5
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
- Record
EUVD-2025-15796- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-4pg4-qvpc-4q3h
7.5
Multer vulnerable to Denial of Service from maliciously crafted requests
Impact
A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to 2.0.0
Workarounds
None
References
- Record
GHSA-4pg4-qvpc-4q3h- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
NVD
7.5
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
- Record
CVE-2025-47944- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
OSV
7.5
Multer vulnerable to Denial of Service from maliciously crafted requests
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
- Record
CVE-2025-47944- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
OSVGHSA-4pg4-qvpc-4q3h
7.5
Multer vulnerable to Denial of Service from maliciously crafted requests
Impact
A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to 2.0.0
Workarounds
None
References
- Record
GHSA-4pg4-qvpc-4q3h- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
OSVCLSA-2026-1773879509 No score
TuxCare security update for multer (3 CVEs)
TuxCare rebuilt multer to address 3 CVEs. Fixed in 1.4.5-lts.1-tuxcare.1.
- Record
CLSA-2026-1773879509- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2025-47944 No score
CVE-2025-47944 in multer - Patched by Root
Root has patched CVE-2025-47944 in the multer package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2025-47944- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
multernpm |
1.4.4-lts.1 up to 2.0.0 | 2.0.0 |
multerTuxCare:npm From an advisory covering 3 CVEs |
1.4.5-lts.1-tuxcare.0 up to 1.4.5-lts.1-tuxcare.1, plus listed versions 1.4.5-lts.1 |
1.4.5-lts.1-tuxcare.1 |
multerRoot:npm |
before 1.4.4-lts.1-aikido.3 | 1.4.4-lts.1-aikido.31.4.5-lts.2-aikido.91.4.5-lts.2-aikido.51.4.4-lts.1-aikido.41.4.4-aikido.21.4.5-lts.1-aikido.21.4.5-lts.1-aikido.31.4.4-aikido.31.4.4-lts.1-aikido.11.4.4-aikido.41.4.5-lts.1-aikido.11.4.4-lts.1-aikido.21.4.4-aikido.51.4.5-lts.2-aikido.61.4.4-aikido.61.4.5-lts.2-aikido.71.4.5-lts.2-aikido.8 |
@rootio/multerRoot:npm |
before 1.4.4-lts.1-root.io.3 | 1.4.4-lts.1-root.io.31.4.5-lts.2-root.io.31.4.5-lts.2-root.io.41.4.5-lts.2-root.io.91.4.5-lts.2-root.io.51.4.4-lts.1-root.io.41.4.4-root.io.21.4.4-root.io.11.4.5-lts.1-root.io.21.4.5-lts.1-root.io.31.4.4-root.io.31.4.4-lts.1-root.io.11.4.4-root.io.41.4.5-lts.1-root.io.11.4.4-lts.1-root.io.21.4.4-root.io.51.4.5-lts.2-root.io.61.4.4-root.io.61.4.5-lts.2-root.io.71.4.5-lts.2-root.io.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-47944 is a high vulnerability (CVSS 7.5) in Expressjs Multer, published May 19, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.81%, the 57th percentile. Fixed in multer 2.0.0.
References
github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h
github.com/expressjs/multer/issues/1176
github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665
nvd.nist.gov/vuln/detail/CVE-2025-47944
github.com/advisories/GHSA-4pg4-qvpc-4q3h
github.com/CVEProject/cvelistV5/tree/main/cves/2025/47xxx/CVE-2025-47944.json
github.com/expressjs/multer