CVE-2025-48997
Multer vulnerable to Denial of Service via unhandled exception
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to 2.0.1 to receive a patch. No known workarounds are available.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.7
Multer vulnerable to Denial of Service via unhandled exception
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to 2.0.1 to receive a patch. No known workarounds are available.
- Record
CVE-2025-48997- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-248
- Updated
- 2026-11-02
EUVDEUVD-2025-16780
8.7
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to 2.0.1 to receive a patch. No known workarounds are available.
- Record
EUVD-2025-16780- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-g5hg-p3ph-g8qg
8.7
Multer vulnerable to Denial of Service via unhandled exception
Impact
A vulnerability in Multer versions >=1.4.4-lts.1, <2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to 2.0.1
Workarounds
None
References
https://github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9 https://github.com/expressjs/multer/issues/1233 https://github.com/expressjs/multer/pull/1256
- Record
GHSA-g5hg-p3ph-g8qg- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-248
- Updated
- 2026-11-02
NVD
8.7
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to 2.0.1 to receive a patch. No known workarounds are available.
- Record
CVE-2025-48997- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-248
- Updated
- 2026-11-02
OSV
8.7
Multer vulnerable to Denial of Service via unhandled exception
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to 2.0.1 to receive a patch. No known workarounds are available.
- Record
CVE-2025-48997- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-248
- Updated
- 2026-11-02
OSVGHSA-g5hg-p3ph-g8qg
8.7
Multer vulnerable to Denial of Service via unhandled exception
Impact
A vulnerability in Multer versions >=1.4.4-lts.1, <2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to 2.0.1
Workarounds
None
References
https://github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9 https://github.com/expressjs/multer/issues/1233 https://github.com/expressjs/multer/pull/1256
- Record
GHSA-g5hg-p3ph-g8qg- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-248
- Updated
- 2026-11-02
OSVCLSA-2026-1773879509 No score
TuxCare security update for multer (3 CVEs)
TuxCare rebuilt multer to address 3 CVEs. Fixed in 1.4.5-lts.1-tuxcare.1.
- Record
CLSA-2026-1773879509- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2025-48997 No score
CVE-2025-48997 in multer - Patched by Root
Root has patched CVE-2025-48997 in the multer package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2025-48997- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
multernpm |
1.4.4-lts.1 up to 2.0.1 | 2.0.1 |
multerTuxCare:npm From an advisory covering 3 CVEs |
1.4.5-lts.1-tuxcare.0 up to 1.4.5-lts.1-tuxcare.1, plus listed versions 1.4.5-lts.1 |
1.4.5-lts.1-tuxcare.1 |
multerRoot:npm |
before 1.4.4-lts.1-aikido.3 | 1.4.4-lts.1-aikido.31.4.5-lts.2-aikido.91.4.5-lts.2-aikido.51.4.4-lts.1-aikido.41.4.5-lts.1-aikido.21.4.5-lts.1-aikido.31.4.4-aikido.31.4.4-aikido.41.4.5-lts.1-aikido.11.4.4-lts.1-aikido.21.4.4-aikido.51.4.5-lts.2-aikido.61.4.4-aikido.61.4.5-lts.2-aikido.71.4.5-lts.2-aikido.8 |
@rootio/multerRoot:npm |
before 1.4.4-lts.1-root.io.3 | 1.4.4-lts.1-root.io.31.4.5-lts.2-root.io.41.4.5-lts.2-root.io.91.4.5-lts.2-root.io.51.4.4-lts.1-root.io.41.4.5-lts.1-root.io.21.4.5-lts.1-root.io.31.4.4-root.io.31.4.4-root.io.41.4.5-lts.1-root.io.11.4.4-lts.1-root.io.21.4.4-root.io.51.4.5-lts.2-root.io.61.4.4-root.io.61.4.5-lts.2-root.io.71.4.5-lts.2-root.io.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-48997 is a high vulnerability (CVSS 8.7) in Expressjs Multer, published June 3, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 41st percentile. Fixed in multer 2.0.1.
References
github.com/expressjs/multer/security/advisories/GHSA-g5hg-p3ph-g8qg
github.com/expressjs/multer/issues/1233
github.com/expressjs/multer/pull/1256
github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9
nvd.nist.gov/vuln/detail/CVE-2025-48997
github.com/advisories/GHSA-g5hg-p3ph-g8qg
github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48997.json
github.com/expressjs/multer