CVE-2025-49147
Umbraco.Cms Vulnerable to Disclosure of Configured Password Requirements
Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.3
Umbraco.Cms Vulnerable to Disclosure of Configured Password Requirements
Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.
- Record
CVE-2025-49147- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-497
- Updated
- 2026-11-02
EUVDEUVD-2025-19053
5.3
Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.
- Record
EUVD-2025-19053- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-pgvc-6h2p-q4f6
5.3
Umbraco CMS disclosure of configured password requirements
Impact
Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password.
The vulnerability can be found in the supported Umbraco versions 10 and 13. It was not exposed in Umbraco 7 or 8, nor in 14 or higher versions.
Patches
Patched in 10.8.11 and 13.9.2
- Record
GHSA-pgvc-6h2p-q4f6- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-497
- Updated
- 2026-11-02
NVD
5.3
Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.
- Record
CVE-2025-49147- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-497
- Updated
- 2026-11-02
OSV
5.3
Umbraco.Cms Vulnerable to Disclosure of Configured Password Requirements
Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.
- Record
CVE-2025-49147- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-497
- Updated
- 2026-11-02
OSVGHSA-pgvc-6h2p-q4f6
5.3
Umbraco CMS disclosure of configured password requirements
Impact
Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password.
The vulnerability can be found in the supported Umbraco versions 10 and 13. It was not exposed in Umbraco 7 or 8, nor in 14 or higher versions.
Patches
Patched in 10.8.11 and 13.9.2
- Record
GHSA-pgvc-6h2p-q4f6- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-497
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
Umbraco.CmsNuGet |
10.0.0 up to 10.8.11 | 10.8.11 |
Umbraco.CmsNuGet |
13.0.0 up to 13.9.2 | 13.9.2 |
Umbraco.CmsNuGet |
10.0.0 up to 10.8.11, plus listed versions 10.0.110.1.010.1.0-rc10.1.0-rc210.1.1 Show 31 moreShow less10.2.010.2.0-rc10.2.110.3.010.3.0-rc10.3.110.3.210.4.010.4.0-rc10.4.110.4.210.5.010.5.0-rc10.5.110.6.010.6.0-rc10.6.110.7.010.7.0-rc10.8.010.8.0-rc10.8.110.8.1010.8.210.8.310.8.410.8.510.8.610.8.710.8.810.8.9 |
10.8.11 |
Umbraco.CmsNuGet |
13.0.0 up to 13.9.2, plus listed versions 13.0.113.0.213.0.313.1.013.1.0-rc Show 31 moreShow less13.1.113.2.013.2.0-rc13.2.113.2.213.3.013.3.0-rc13.3.113.3.213.4.013.4.0-rc13.4.0-rc213.4.113.5.013.5.0-rc13.5.113.5.213.5.313.6.013.6.0-rc13.6.0-rc213.7.013.7.0-rc13.7.113.7.213.8.013.8.0-rc13.8.113.9.013.9.0-rc13.9.1 |
13.9.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-49147 is a medium vulnerability (CVSS 5.3) in Umbraco Cms, published June 24, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in Umbraco.Cms 10.8.11.
References
github.com/umbraco/Umbraco-CMS/security/advisories/GHSA-pgvc-6h2p-q4f6
github.com/umbraco/Umbraco-CMS/commit/b4144564c836ec6929111ce2a12eb1f67b42d61e
github.com/umbraco/Umbraco-CMS/commit/d8f68d2c40f8e158bd81d469f25ef3a4e1d86c4c
nvd.nist.gov/vuln/detail/CVE-2025-49147
github.com/advisories/GHSA-pgvc-6h2p-q4f6
github.com/CVEProject/cvelistV5/tree/main/cves/2025/49xxx/CVE-2025-49147.json
github.com/umbraco/Umbraco-CMS