Every CVE Search/ Get API key

CVE-2025-49656

Apache Jena: Administrative users can create files outside the server directory space via the admin UI

7.5 HighFix available

Users with administrator access can create databases files outside the files area of the Fuseki server.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.56%Up 1.5 points since Jul 21, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.5

Apache Jena: Administrative users can create files outside the server directory space via the admin UI

Users with administrator access can create databases files outside the files area of the Fuseki server.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Record
CVE-2025-49656
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
EUVDEUVD-2025-22076 7.5

Users with administrator access can create databases files outside the files area of the Fuseki server.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Record
EUVD-2025-22076
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-jq2c-m8gg-mqcm 4.9

Apache Jena allows users with administrator access to create databases files outside the files area of the Fuseki server

Users with administrator access can create databases files outside the files area of the Fuseki server.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Record
GHSA-jq2c-m8gg-mqcm
CVSS 3.1
4.9 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
NVD 7.5

Users with administrator access can create databases files outside the files area of the Fuseki server.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Record
CVE-2025-49656
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV 7.5

Users with administrator access can create databases files outside the files area of the Fuseki server.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Record
CVE-2025-49656
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2025-49656 7.5

Users with administrator access can create databases files outside the files area of the Fuseki server. This issue affects Apache Jena version up to 5.4.0. Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Record
DEBIAN-CVE-2025-49656
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-jq2c-m8gg-mqcm 4.9

Apache Jena allows users with administrator access to create databases files outside the files area of the Fuseki server

Users with administrator access can create databases files outside the files area of the Fuseki server.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Record
GHSA-jq2c-m8gg-mqcm
CVSS 3.1
4.9 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVUBUNTU-CVE-2025-49656 7.5

Users with administrator access can create databases files outside the files area of the Fuseki server. This issue affects Apache Jena version up to 5.4.0. Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Record
UBUNTU-CVE-2025-49656
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.jena:jena-fuseki
Maven
before 5.5.0
5.5.0
apache-jena
Debian:12
All versions, plus listed versions
4.5.0-24.9.0-1
None known
apache-jena
Debian:13
All versions, plus listed versions
4.9.0-1
None known
apache-jena
Debian:14
All versions, plus listed versions
4.9.0-1
None known
org.apache.jena:jena-fuseki
Maven
before 5.5.0, plus listed versions
0.2.1-incubating0.2.20.2.30.2.40.2.5
Show 45 moreShow less
0.2.60.2.71.0.01.0.11.0.21.1.01.1.12.0.02.3.02.3.12.4.02.4.12.5.02.6.03.10.03.11.03.12.03.13.03.13.13.14.03.15.03.16.03.17.03.4.03.5.03.6.03.7.03.8.03.9.04.0.04.1.04.10.04.2.04.3.04.3.14.3.24.4.04.5.04.6.04.6.14.7.04.8.04.9.05.0.05.0.0-rc1
5.5.0
apache-jena
Ubuntu:22.04:LTS
All versions, plus listed versions
3.17.0-13.17.0-23.17.0-3
None known
apache-jena
Ubuntu:24.04:LTS
All versions, plus listed versions
4.5.0-24.9.0-1
None known
apache-jena
Ubuntu:25.10
All versions, plus listed versions
4.9.0-1
None known
apache-jena
Ubuntu:26.10
All versions, plus listed versions
4.9.0-1build1
None known
apache-jena
Ubuntu:26.04:LTS
All versions, plus listed versions
4.9.0-14.9.0-1build1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-49656 is a high vulnerability (CVSS 7.5) in Apache Jena, published July 21, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.56%, the 75th percentile. Fixed in org.apache.jena:jena-fuseki 5.5.0.

References

Show 4 moreShow less
This page doesn't list everything

Left out here: 4 versions. The JSON record has them.

MoveEnter Open