Every CVE Search/ Get API key

CVE-2025-51471

Ollama vulnerable to Cross-Domain Token Exposure

6.9 MediumPublic exploit

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
Low
Availability
None

Exploit likelihood

18.5%Up 18.5 points since Jul 23, 2025
90%50%10%1%

What each source reports

CVE List Score used 6.9

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.

Record
CVE-2025-51471
CVSS 3.1
6.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
Weakness
CWE-384, CWE-345
Updated
2026-11-02
EUVDEUVD-2025-22351 6.9

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.

Record
EUVD-2025-22351
CVSS 3.1
6.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-x9hg-5q6g-q3jr 6.9

Ollama vulnerable to Cross-Domain Token Exposure

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.

Record
GHSA-x9hg-5q6g-q3jr
CVSS 3.1
6.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
Weakness
CWE-345
Updated
2026-11-02
NVD 6.9

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.

Record
CVE-2025-51471
CVSS 3.1
6.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
Weakness
CWE-345, CWE-384
Updated
2026-11-02
OSV 6.9

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.

Record
CVE-2025-51471
CVSS 3.1
6.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
Updated
2026-11-02
OSVGHSA-x9hg-5q6g-q3jr 6.9

Ollama vulnerable to Cross-Domain Token Exposure

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.

Record
GHSA-x9hg-5q6g-q3jr
CVSS 3.1
6.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
Weakness
CWE-345
Updated
2026-11-02
OSVPYSEC-2025-147 6.9

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.

Record
PYSEC-2025-147
CVSS 3.1
6.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
Updated
2026-11-02
OSVGO-2025-3824 No score

Ollama vulnerable to Cross-Domain Token Exposure in github.com/ollama/ollama

Ollama vulnerable to Cross-Domain Token Exposure in github.com/ollama/ollama

Record
GO-2025-3824
Updated
2026-11-02
OSVopenSUSE-SU-2025:15405-1 No score

govulncheck-vulndb-0.0.20250730T213748-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250730T213748-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15405-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/ollama/ollama
Go
through 0.9.6 None known
github.com/ollama/ollama
Go
All versions None known
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 56 CVEs
before 0.0.20250730T213748-1.1
0.0.20250730T213748-1.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubajtazer/CVE-2025-51471-POC2025-12-24

History

History
RecordedChangedSources
affected, facts
affected
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-51471 is a medium vulnerability (CVSS 6.9) in Ollama, published July 22, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 18.5%, the 97th percentile. No source names a fixed version.

References

Show 58 moreShow less
MoveEnter Open