CVE-2025-51495
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By...
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
- Record
CVE-2025-51495- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
EUVDEUVD-2025-31586
7.5
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
- Record
EUVD-2025-31586- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-83rc-g55p-8xj2
7.5
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By...
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
- Record
GHSA-83rc-g55p-8xj2- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-121, CWE-190
- Updated
- 2026-11-02
NVD
7.5
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
- Record
CVE-2025-51495- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-07
OSV
7.5
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
- Record
CVE-2025-51495- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-51495
7.5
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
- Record
DEBIAN-CVE-2025-51495- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-51495
7.5
An integer overflow vulnerability exists in the WebSocket component of Mongoose 7.5 thru 7.17. By sending a specially crafted WebSocket request, an attacker can cause the application to crash. If downstream vendors integrate this component improperly, the issue may lead to a buffer overflow.
- Record
UBUNTU-CVE-2025-51495- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
swupdateDebian:12 |
All versions, plus listed versions 2022.12+dfsg-42022.12+dfsg-4+deb12u12022.12+dfsg-4+deb12u1~bpo11+12022.12+dfsg-4+deb12u22023.05+dfsg-1 Show 45 moreShow less2023.05+dfsg-22023.05+dfsg-2~bpo12+12023.05+dfsg-32023.05+dfsg-42023.05+dfsg-52023.05+dfsg-5~bpo12+12023.12+dfsg-12023.12+dfsg-1~bpo12+12023.12.1+dfsg-12023.12.1+dfsg-1~bpo12+12023.12.1+dfsg-22023.12.1+dfsg-2~bpo12+12024.05+dfsg-12024.05.2+dfsg-12024.05.2+dfsg-22024.05.2+dfsg-2~bpo12+12024.12+dfsg-12024.12+dfsg-22024.12+dfsg-2~bpo12+12024.12.1+dfsg-12024.12.1+dfsg-1~bpo12+12024.12.1+dfsg-22024.12.1+dfsg-32024.12.1+dfsg-3~bpo12+12025.05+dfsg-12025.05+dfsg-22025.05+dfsg-2~bpo13+12025.05+dfsg-32025.05+dfsg-3~bpo13+12025.12+dfsg-12025.12+dfsg-102025.12+dfsg-10~bpo13+12025.12+dfsg-10~bpo13+22025.12+dfsg-22025.12+dfsg-2~bpo13+12025.12+dfsg-32025.12+dfsg-42025.12+dfsg-52025.12+dfsg-62025.12+dfsg-72025.12+dfsg-7~bpo13+12025.12+dfsg-82025.12+dfsg-92026.05+dfsg-12026.05+dfsg-2 |
None known |
swupdateDebian:13 |
All versions, plus listed versions 2024.12.1+dfsg-32024.12.1+dfsg-3+deb13u12024.12.1+dfsg-3+deb13u22025.05+dfsg-12025.05+dfsg-2 Show 24 moreShow less2025.05+dfsg-2~bpo13+12025.05+dfsg-32025.05+dfsg-3~bpo13+12025.12+dfsg-12025.12+dfsg-102025.12+dfsg-10~bpo13+12025.12+dfsg-10~bpo13+22025.12+dfsg-22025.12+dfsg-2~bpo13+12025.12+dfsg-32025.12+dfsg-42025.12+dfsg-52025.12+dfsg-62025.12+dfsg-72025.12+dfsg-7~bpo13+12025.12+dfsg-82025.12+dfsg-92026.05+dfsg-12026.05+dfsg-22026.05+dfsg-32026.05+dfsg-3~bpo13+12026.05+dfsg-42026.05.1+dfsg-12026.05.1+dfsg-1~bpo13+1 |
None known |
swupdateDebian:14 |
before 2025.12+dfsg-1, plus listed versions 2024.12.1+dfsg-32025.05+dfsg-12025.05+dfsg-22025.05+dfsg-2~bpo13+12025.05+dfsg-32025.05+dfsg-3~bpo13+1 |
2025.12+dfsg-1 |
swupdateUbuntu:22.04:LTS |
All versions, plus listed versions 2020.11-22021.04-1.12021.04-22021.04-2build12021.11-1 |
None known |
swupdateUbuntu:24.04:LTS |
All versions, plus listed versions 2023.05+dfsg-32023.05+dfsg-42023.05+dfsg-4build12023.05+dfsg-52023.12+dfsg-12023.12.1+dfsg-1ubuntu12023.12.1+dfsg-1ubuntu42023.12.1+dfsg-1ubuntu5 |
None known |
swupdateUbuntu:25.10 |
All versions, plus listed versions 2024.12.1+dfsg-1build22024.12.1+dfsg-22024.12.1+dfsg-32025.05+dfsg-2ubuntu1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | cainiao159357/CVE-2025-51495 | 2025-09-25 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | NVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-51495 is a high vulnerability (CVSS 7.5) in Cesanta Mongoose, published September 29, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.42%, the 36th percentile. Fixed in swupdate 2025.12+dfsg-1.
References
Left out here: 5 versions. The JSON record has them.