CVE-2025-52099
Integer Overflow vulnerability in SQLite SQLite3 v.3.50.0 allows a remote attacker to cause a...
CVE-2025-52099 has been rejected by its source and should not be treated as a live vulnerability, published October 24, 2025. Public exploit code exists. Fixed in sqlite 3.49.1-r0.
DO NOT USE THIS CVE RECORD. ConsultIDs: CVE-2025-29088. Reason: This record is a duplicate of CVE-2025-29088. Notes: All CVE users should reference CVE-2025-29088 instead of this record. All references and descriptions in this record have been removed to prevent accidental usage.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
What each source reports
GitHub Advisories Score usedGHSA-chjr-9v3v-pr2f
7.5
Integer Overflow vulnerability in SQLite SQLite3 v.3.50.0 allows a remote attacker to cause a...
Integer Overflow vulnerability in SQLite SQLite3 v.3.50.0 allows a remote attacker to cause a denial of service via the setupLookaside function
- Record
GHSA-chjr-9v3v-pr2f- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
CVE List No score
DO NOT USE THIS CVE RECORD. ConsultIDs: CVE-2025-29088. Reason: This record is a duplicate of CVE-2025-29088. Notes: All CVE users should reference CVE-2025-29088 instead of this record. All references and descriptions in this record have been removed to prevent accidental usage.
- Record
CVE-2025-52099- Updated
- 2026-11-02
EUVDEUVD-2025-35887 No score
DO NOT USE THIS CVE RECORD. ConsultIDs: CVE-2025-29088. Reason: This record is a duplicate of CVE-2025-29088. Notes: All CVE users should reference CVE-2025-29088 instead of this record. All references and descriptions in this record have been removed to prevent accidental usage.
- Record
EUVD-2025-35887- Updated
- 2026-11-02
NVD No score
Rejected reason: DO NOT USE THIS CVE RECORD. ConsultIDs: CVE-2025-29088. Reason: This record is a duplicate of CVE-2025-29088. Notes: All CVE users should reference CVE-2025-29088 instead of this record. All references and descriptions in this record have been removed to prevent accidental usage.
- Record
CVE-2025-52099- Updated
- 2026-11-02
OSVBELL-CVE-2025-52099
7.5
- Record
BELL-CVE-2025-52099- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-52099
7.5
Integer Overflow vulnerability in SQLite SQLite3 v.3.50.0 allows a remote attacker to cause a denial of service via the setupLookaside function
- Record
DEBIAN-CVE-2025-52099- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-52099
7.5
Rejected reason: DO NOT USE THIS CVE RECORD. ConsultIDs: CVE-2025-29088. Reason: This record is a duplicate of CVE-2025-29088. Notes: All CVE users should reference CVE-2025-29088 instead of this record. All references and descriptions in this record have been removed to prevent accidental usage.
- Record
UBUNTU-CVE-2025-52099- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sqliteAlpaquita:stream |
3.49.0-r1 up to 3.49.1-r0 | 3.49.1-r0 |
sqliteBellSoft Hardened Containers:stream |
3.49.0-r1 up to 3.49.1-r0 | 3.49.1-r0 |
sqlite3Ubuntu:Pro:14.04:LTS |
before 3.8.2-1ubuntu2.2+esm5, plus listed versions 3.7.17-1ubuntu13.8.0.2-1ubuntu13.8.1-1ubuntu13.8.1-1ubuntu33.8.2-1ubuntu1 Show 7 moreShow less3.8.2-1ubuntu23.8.2-1ubuntu2.13.8.2-1ubuntu2.23.8.2-1ubuntu2.2+esm13.8.2-1ubuntu2.2+esm23.8.2-1ubuntu2.2+esm33.8.2-1ubuntu2.2+esm4 |
3.8.2-1ubuntu2.2+esm5 |
sqlite3Ubuntu:Pro:16.04:LTS |
before 3.11.0-1ubuntu1.5+esm3, plus listed versions 3.8.11.1-13.9.1-23.9.2-13.10.0-13.10.1-1 Show 9 moreShow less3.10.2-13.11.0-1ubuntu13.11.0-1ubuntu1.13.11.0-1ubuntu1.23.11.0-1ubuntu1.33.11.0-1ubuntu1.43.11.0-1ubuntu1.53.11.0-1ubuntu1.5+esm13.11.0-1ubuntu1.5+esm2 |
3.11.0-1ubuntu1.5+esm3 |
sqlite3Ubuntu:Pro:18.04:LTS |
before 3.22.0-1ubuntu0.7+esm2, plus listed versions 3.19.3-33.20.1-23.21.0-13.22.0-13.22.0-1ubuntu0.1 Show 7 moreShow less3.22.0-1ubuntu0.23.22.0-1ubuntu0.33.22.0-1ubuntu0.43.22.0-1ubuntu0.53.22.0-1ubuntu0.63.22.0-1ubuntu0.73.22.0-1ubuntu0.7+esm1 |
3.22.0-1ubuntu0.7+esm2 |
sqlite3Ubuntu:20.04:LTS |
before 3.31.1-4ubuntu0.7, plus listed versions 3.29.0-23.30.1-13.30.1-1ubuntu13.31.1-1ubuntu13.31.1-3 Show 7 moreShow less3.31.1-43.31.1-4ubuntu0.13.31.1-4ubuntu0.23.31.1-4ubuntu0.33.31.1-4ubuntu0.43.31.1-4ubuntu0.53.31.1-4ubuntu0.6 |
3.31.1-4ubuntu0.7 |
sqlite3Ubuntu:22.04:LTS |
before 3.37.2-2ubuntu0.4, plus listed versions 3.35.5-13.36.0-23.37.2-23.37.2-2ubuntu0.13.37.2-2ubuntu0.3 |
3.37.2-2ubuntu0.4 |
sqlite3Ubuntu:24.04:LTS |
before 3.45.1-1ubuntu2.3, plus listed versions 3.42.0-13.44.0-13.44.2-13.45.0-13.45.1-13.45.1-1ubuntu13.45.1-1ubuntu23.45.1-1ubuntu2.1 |
3.45.1-1ubuntu2.3 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | SCREAMBBY/CVE-2025-52099 | 2025-10-24 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | affected | |
| 2026-11-02 | created | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |