CVE-2025-52582
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality...
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.4
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.
- Record
CVE-2025-52582- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
EUVDEUVD-2025-203850
7.4
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.
- Record
EUVD-2025-203850- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-xqwf-q6p3-jgrr
7.4
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality...
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.
- Record
GHSA-xqwf-q6p3-jgrr- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119, CWE-125
- Updated
- 2026-11-02
NVD
7.4
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.
- Record
CVE-2025-52582- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-119, CWE-125
- Updated
- 2026-11-02
OSV
7.4
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.
- Record
CVE-2025-52582- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-52582
7.5
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.
- Record
DEBIAN-CVE-2025-52582- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-52582
7.4
An out-of-bounds read vulnerability exists in the Overlay::GrabOverlayFromPixelData functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.
- Record
UBUNTU-CVE-2025-52582- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gdcmDebian:12 |
All versions, plus listed versions 3.0.21-13.0.21-23.0.22-13.0.22-23.0.22-2.1 Show 20 moreShow less3.0.22-2.1~exp13.0.22-33.0.24-13.0.24-1+hurd.13.0.24-103.0.24-113.0.24-123.0.24-133.0.24-143.0.24-23.0.24-33.0.24-3+hurd.13.0.24-43.0.24-53.0.24-5+hurd.13.0.24-5+hurd.23.0.24-63.0.24-73.0.24-83.0.24-9 |
None known |
gdcmDebian:13 |
All versions, plus listed versions 3.0.24-103.0.24-113.0.24-123.0.24-133.0.24-14 Show 7 moreShow less3.0.24-53.0.24-5+hurd.13.0.24-5+hurd.23.0.24-63.0.24-73.0.24-83.0.24-9 |
None known |
gdcmDebian:14 |
before 3.0.24-11, plus listed versions 3.0.24-103.0.24-53.0.24-5+hurd.13.0.24-5+hurd.23.0.24-63.0.24-73.0.24-83.0.24-9 |
3.0.24-11 |
gdcmUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 2.2.3-2ubuntu32.2.3-2ubuntu42.2.4-1.1ubuntu12.2.4-1.1ubuntu22.2.4-1.1ubuntu32.2.4-1.1ubuntu42.2.4-1.1ubuntu4+esm1 |
None known |
gdcmUbuntu:16.04:LTS |
All versions, plus listed versions 2.4.4-42.4.4-4build12.4.4-4ubuntu12.6.1-32.6.2-1 Show 7 moreShow less2.6.2-22.6.2-32.6.3-12.6.3-1ubuntu12.6.3-2ubuntu12.6.3-3ubuntu12.6.3-3ubuntu3 |
None known |
gdcmUbuntu:18.04:LTS |
All versions, plus listed versions 2.8.2-3build12.8.3-12.8.4-12.8.4-1build2 |
None known |
gdcmUbuntu:20.04:LTS |
All versions, plus listed versions 2.8.8-9ubuntu42.8.8-9ubuntu53.0.4-23.0.4-2build13.0.4-2ubuntu13.0.5-1ubuntu13.0.5-1.1ubuntu13.0.5-1.1ubuntu2 |
None known |
gdcmUbuntu:22.04:LTS |
All versions, plus listed versions 3.0.8-23.0.10-13.0.10-1build2 |
None known |
gdcmUbuntu:24.04:LTS |
All versions, plus listed versions 3.0.21-23.0.22-13.0.22-2build13.0.22-2build23.0.22-2.1build13.0.22-2.1build23.0.22-2.1ubuntu1 |
None known |
gdcmUbuntu:25.10 |
All versions, plus listed versions 3.0.24-5ubuntu23.0.24-5ubuntu3 |
None known |
gdcmUbuntu:26.10 |
All versions, plus listed versions 3.0.24-9ubuntu13.0.24-103.0.24-113.0.24-12ubuntu13.0.24-14 |
None known |
gdcmUbuntu:26.04:LTS |
All versions, plus listed versions 3.0.24-5ubuntu33.0.24-7ubuntu13.0.24-93.0.24-9ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-52582 is a high vulnerability (CVSS 7.4) in Grassroot Dicom Dicom, published December 16, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 35th percentile. Fixed in gdcm 3.0.24-11.
References
talosintelligence.com/vulnerability_reports/TALOS-2025-2211
nvd.nist.gov/vuln/detail/CVE-2025-52582
github.com/advisories/GHSA-xqwf-q6p3-jgrr
github.com/CVEProject/cvelistV5/tree/main/cves/2025/52xxx/CVE-2025-52582.json
security-tracker.debian.org/tracker/CVE-2025-52582
ubuntu.com/security/CVE-2025-52582
cve.org/CVERecord?id=CVE-2025-52582