CVE-2025-53510
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL...
CVE-2025-53510 is a high vulnerability (CVSS 8.8) in Sail, published August 25, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 52nd percentile. Fixed in sail 0.9.8-1+deb13u1.
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
- Record
CVE-2025-53510- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-680
- Updated
- 2026-11-02
EUVDEUVD-2025-28528
8.8
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
- Record
EUVD-2025-28528- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-c4w7-fxp3-j9r3
8.8
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL...
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
- Record
GHSA-c4w7-fxp3-j9r3- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-680
- Updated
- 2026-11-02
NVD
8.8
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
- Record
CVE-2025-53510- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-680
- Updated
- 2026-11-02
OSV
8.8
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
- Record
CVE-2025-53510- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-680
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-53510
8.8
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
- Record
DEBIAN-CVE-2025-53510- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-53510
8.8
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
- Record
UBUNTU-CVE-2025-53510- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sailDebian:13 |
before 0.9.8-1+deb13u1, plus listed versions 0.9.8-1 |
0.9.8-1+deb13u1 |
sailDebian:14 |
before 0.9.9-1, plus listed versions 0.9.8-1 |
0.9.9-1 |
sailUbuntu:24.04:LTS |
All versions, plus listed versions 0.9.0+repack-10.9.0+repack-20.9.0+repack-2.10.9.0+repack-2.1build1 |
None known |
sailUbuntu:25.10 |
All versions, plus listed versions 0.9.7-1build10.9.8-10.9.9-1 |
None known |
sailUbuntu:26.10 |
All versions, plus listed versions 0.9.10-10.9.10-3 |
None known |
sailUbuntu:26.04:LTS |
All versions, plus listed versions 0.9.9-10.9.10-1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-02 | created | CVE List, EUVD, GitHub Advisories, NVD, OSV |
References
talosintelligence.com/vulnerability_reports/TALOS-2025-2218
nvd.nist.gov/vuln/detail/CVE-2025-53510
github.com/advisories/GHSA-c4w7-fxp3-j9r3
github.com/CVEProject/cvelistV5/tree/main/cves/2025/53xxx/CVE-2025-53510.json
security-tracker.debian.org/tracker/CVE-2025-53510
ubuntu.com/security/CVE-2025-53510
cve.org/CVERecord?id=CVE-2025-53510