CVE-2025-53537
LibHTP's memory leak with lzma can lead to resource starvation
LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled to false. This issue is fixed in version 0.5.51.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
LibHTP's memory leak with lzma can lead to resource starvation
LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled to false. This issue is fixed in version 0.5.51.
- Record
CVE-2025-53537- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-02
EUVDEUVD-2025-22472
7.5
LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled to false. This issue is fixed in version 0.5.51.
- Record
EUVD-2025-22472- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
NVD
7.5
LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled to false. This issue is fixed in version 0.5.51.
- Record
CVE-2025-53537- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-02
OSV
7.5
LibHTP's memory leak with lzma can lead to resource starvation
LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled to false. This issue is fixed in version 0.5.51.
- Record
CVE-2025-53537- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-53537
7.5
LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled to false. This issue is fixed in version 0.5.51.
- Record
DEBIAN-CVE-2025-53537- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-53537
7.5
LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled to false. This issue is fixed in version 0.5.51.
- Record
UBUNTU-CVE-2025-53537- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-7814-1 No score
libhtp vulnerabilities
It was discovered that LibHTP did not correctly handle certain HTTP headers. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2024-23837)
It was discovered that LibHTP did not correctly parse certain HTTP requests. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 20.04 LTS, Ubuntu 22.04 LTS and Ubuntu 24.04 LTS. (CVE-2024-28871)
It was discovered that LibHTP did not correctly parse certain HTTP requests. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2024-45797)
It was discovered that LibHTP did not correctly handle certain memory operations. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS and Ubuntu 25.04. (CVE-2025-53537)
- Record
USN-7814-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libhtpDebian:13 |
before 1:0.5.50-1+deb13u1, plus listed versions 1:0.5.50-11:0.5.50-1+deb13u1~bpo12+1 |
1:0.5.50-1+deb13u1 |
libhtpUbuntu:Pro:16.04:LTS |
before 0.5.15-1ubuntu0.1~esm1, plus listed versions 0.5.15-1 |
0.5.15-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:18.04:LTS |
before 1:0.5.26-1ubuntu0.1~esm1, plus listed versions 1:0.5.25-11:0.5.26-1 |
1:0.5.26-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:20.04:LTS |
before 1:0.5.32-1ubuntu0.1~esm1, plus listed versions 1:0.5.30-11:0.5.31-11:0.5.32-1 |
1:0.5.32-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:22.04:LTS |
before 1:0.5.39-1ubuntu0.1~esm1, plus listed versions 1:0.5.36-11:0.5.38-11:0.5.39-1 |
1:0.5.39-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:24.04:LTS |
before 1:0.5.46-1ubuntu2+esm1, plus listed versions 1:0.5.45-11:0.5.46-1ubuntu11:0.5.46-1ubuntu2 |
1:0.5.46-1ubuntu2+esm1 |
libhtpUbuntu:25.10 |
All versions, plus listed versions 1:0.5.49-11:0.5.50-1 |
None known |
libhtpUbuntu:26.04:LTS |
All versions, plus listed versions 1:0.5.50-11:0.5.52-11:0.5.52-2 |
None known |
libhtpUbuntu:Pro:16.04:LTS From an advisory covering 4 CVEs |
before 0.5.15-1ubuntu0.1~esm1, plus listed versions 0.5.15-1 |
0.5.15-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:18.04:LTS From an advisory covering 4 CVEs |
before 1:0.5.26-1ubuntu0.1~esm1, plus listed versions 1:0.5.25-11:0.5.26-1 |
1:0.5.26-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:20.04:LTS From an advisory covering 4 CVEs |
before 1:0.5.32-1ubuntu0.1~esm1, plus listed versions 1:0.5.30-11:0.5.31-11:0.5.32-1 |
1:0.5.32-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:22.04:LTS From an advisory covering 4 CVEs |
before 1:0.5.39-1ubuntu0.1~esm1, plus listed versions 1:0.5.36-11:0.5.38-11:0.5.39-1 |
1:0.5.39-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:24.04:LTS From an advisory covering 4 CVEs |
before 1:0.5.46-1ubuntu2+esm1, plus listed versions 1:0.5.45-11:0.5.46-1ubuntu11:0.5.46-1ubuntu2 |
1:0.5.46-1ubuntu2+esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-53537 is a high vulnerability (CVSS 7.5) in Oisf Libhtp, published July 23, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.50%, the 43rd percentile. Fixed in libhtp 1:0.5.50-1+deb13u1.
References
github.com/OISF/libhtp/security/advisories/GHSA-v3qq-h8mh-vph7
github.com/OISF/libhtp/commit/9037ea35110a0d97be5cedf8d31fb4cd9a38c7a7
github.com/CVEProject/cvelistV5/tree/main/cves/2025/53xxx/CVE-2025-53537.json
nvd.nist.gov/vuln/detail/CVE-2025-53537
security-tracker.debian.org/tracker/CVE-2025-53537
ubuntu.com/security/CVE-2025-53537