CVE-2025-54314
Withdrawn Advisory: Thor can construct an unsafe shell command from library input.
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
2.8
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
- Record
CVE-2025-54314- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N - Weakness
- CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2025-21984
2.8
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
- Record
EUVD-2025-21984- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mqcp-p2hv-vw6x
7.8
Withdrawn Advisory: Thor can construct an unsafe shell command from library input.
Withdrawn Advisory
This advisory has been withdrawn because the method described can only be used with arguments that are controlled by Thor, and an external attacker cannot access the functionality described in the body of the CVE. This link is maintained to preserve external references.
Original Description
Thor before 1.4.0 can construct an unsafe shell command from library input.
- Record
GHSA-mqcp-p2hv-vw6x- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
NVD
2.8
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
- Record
CVE-2025-54314- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
2.8
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
- Record
CVE-2025-54314- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N - Weakness
- CWE-78
- Updated
- 2026-11-02
OSVGHSA-mqcp-p2hv-vw6x
7.8
Withdrawn Advisory: Thor can construct an unsafe shell command from library input.
Withdrawn Advisory
This advisory has been withdrawn because the method described can only be used with arguments that are controlled by Thor, and an external attacker cannot access the functionality described in the body of the CVE. This link is maintained to preserve external references.
Original Description
Thor before 1.4.0 can construct an unsafe shell command from library input.
- Record
GHSA-mqcp-p2hv-vw6x- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2025-54314
2.8
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
- Record
UBUNTU-CVE-2025-54314- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N - Updated
- 2026-11-02
OSVAZL-65613 No score
CVE-2025-54314 affecting package rubygem-thor 1.2.1-1
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
- Record
AZL-65613- Updated
- 2026-11-05
OSVAZL-65631 No score
CVE-2025-54314 affecting package rubygem-thor for versions less than 1.2.1-3
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
- Record
AZL-65631- Updated
- 2026-11-02
OSVopenSUSE-SU-2025:15382-1 No score
ruby3.4-rubygem-thor-1.4.0-1.1 on GA media
These are all security issues fixed in the ruby3.4-rubygem-thor-1.4.0-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:15382-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:10366-1 No score
ruby4.0-rubygem-thor-1.4.0-1.3 on GA media
These are all security issues fixed in the ruby4.0-rubygem-thor-1.4.0-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:10366-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
rubygem-thorAzure Linux:3 |
through 1.2.1-1 | None known |
rubygem-thorAzure Linux:2 |
before 1.2.1-3 | 1.2.1-3 |
ruby-thorUbuntu:14.04:LTS |
All versions, plus listed versions 0.18.1-10.18.1.git20140116-2 |
None known |
ruby-thorUbuntu:16.04:LTS |
All versions, plus listed versions 0.19.1-2 |
None known |
ruby-thorUbuntu:18.04:LTS |
All versions, plus listed versions 0.19.4-1 |
None known |
ruby-thorUbuntu:20.04:LTS |
All versions, plus listed versions 0.19.4-1 |
None known |
ruby-thorUbuntu:22.04:LTS |
All versions, plus listed versions 1.0.1-1 |
None known |
ruby-thorUbuntu:24.04:LTS |
All versions, plus listed versions 1.2.1-21.2.2-11.3.1-1 |
None known |
ruby-thorUbuntu:25.10 |
All versions, plus listed versions 1.3.2-21.3.2-2.1 |
None known |
ruby-thorUbuntu:26.10 |
All versions, plus listed versions 1.5.0-1 |
None known |
ruby-thorUbuntu:26.04:LTS |
All versions, plus listed versions 1.3.2-2.11.4.0-11.5.0-1 |
None known |
rubygem-thoropenSUSE:Tumbleweed |
before 1.4.0-1.1 | 1.4.0-1.1 |
rubygem-thoropenSUSE:Tumbleweed |
before 1.4.0-1.3 | 1.4.0-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| affected | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-54314 is a low vulnerability (CVSS 2.8) in Rubyonrails Thor, published July 20, 2025. Its validity is disputed. EPSS puts the chance of exploitation in the next 30 days at 0.19%, the 8th percentile. Fixed in rubygem-thor 1.2.1-3.
References
github.com/rails/thor/commit/536b79036a0efb765c1899233412e7b1ca94abfa
hackerone.com/reports/3260153
github.com/rails/thor/pull/897
github.com/rails/thor/releases/tag/v1.4.0
github.com/github/advisory-database/pull/5912
nvd.nist.gov/vuln/detail/CVE-2025-54314
Show 7 moreShow less
github.com/rubysec/ruby-advisory-db/blob/master/gems/thor/CVE-2025-54314.yml
github.com/advisories/GHSA-mqcp-p2hv-vw6x
github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54314.json
github.com/rails/thor
ubuntu.com/security/CVE-2025-54314
cve.org/CVERecord?id=CVE-2025-54314
suse.com/security/cve/CVE-2025-54314