CVE-2025-54384
CKAN stored XSS vulnerability in Markdown description fields
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.3
CKAN stored XSS vulnerability in Markdown description fields
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
- Record
CVE-2025-54384- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2025-36667
6.3
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
- Record
EUVD-2025-36667- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-2r4h-8jxv-w2j8
6.3
CKAN vulnerable to stored XSS in resource description
Impact
The helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector.
Patches
This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4
- Record
GHSA-2r4h-8jxv-w2j8- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
6.3
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
- Record
CVE-2025-54384- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.3
CKAN stored XSS vulnerability in Markdown description fields
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
- Record
CVE-2025-54384- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-2r4h-8jxv-w2j8
6.3
CKAN vulnerable to stored XSS in resource description
Impact
The helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector.
Patches
This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4
- Record
GHSA-2r4h-8jxv-w2j8- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVPYSEC-2026-1247
6.3
CKAN vulnerable to stored XSS in resource description
Impact
The helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector.
Patches
This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4
- Record
PYSEC-2026-1247- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ckanPyPI |
2.11.0 up to 2.11.4 | 2.11.4 |
ckanPyPI |
before 2.10.9 | 2.10.9 |
ckanPyPI |
2.11.0 up to 2.11.4, plus listed versions 2.11.12.11.22.11.3 |
2.11.4 |
ckanPyPI |
before 2.10.9, plus listed versions 0.110.30.40.50.6 Show 45 moreShow less0.70.81.01.11.21.31.3.21.3.31.41.4.11.4.21.4.31.4.3.11.51.5.11.61.71.7.11.82.02.0.12.0.72.0.82.12.1.12.1.52.1.62.10.02.10.12.10.32.10.42.10.52.10.62.10.72.10.82.22.2.12.2.32.2.42.32.3.12.3.22.3.32.3.42.3.5 |
2.10.9 |
ckanPyPI |
before 2.10.9, 2.11.0 up to 2.11.4, plus listed versions 0.110.30.40.50.6 Show 45 moreShow less0.70.81.01.11.21.31.3.21.3.31.41.4.11.4.21.4.31.4.3.11.51.5.11.61.71.7.11.82.02.0.12.0.72.0.82.12.1.12.1.52.1.62.10.02.10.12.10.32.10.42.10.52.10.62.10.72.10.82.11.12.11.22.11.32.22.2.12.2.32.2.42.32.3.12.3.2 |
2.10.92.11.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-54384 is a medium vulnerability (CVSS 6.3) in Ckan, published October 29, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.23%, the 13th percentile. Fixed in ckan 2.11.4.
References
github.com/ckan/ckan/security/advisories/GHSA-2r4h-8jxv-w2j8
github.com/ckan/ckan/commit/6d0065f2fc7e2682196d125275af34b93e9e554e
github.com/ckan/ckan/commit/112affffa74b14fc97c54abcf18315df97114917
github.com/ckan/ckan/releases/tag/ckan-2.10.9
github.com/ckan/ckan/releases/tag/ckan-2.11.4
nvd.nist.gov/vuln/detail/CVE-2025-54384
Left out here: 131 versions. The JSON record has them.