Every CVE Search/ Get API key

CVE-2025-54417

Craft contains a theoretical bypass for CVE-2025-23209

5.2 MediumFix available

Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.53%Up 0.5 points since Aug 9, 2025
90%50%10%1%

What each source reports

CVE List Score used 5.2

Craft contains a theoretical bypass for CVE-2025-23209

Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.

Record
CVE-2025-54417
CVSS 4.0
5.2 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2025-24040 5.2

Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.

Record
EUVD-2025-24040
CVSS 4.0
5.2 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Updated
2026-11-02
GitHub AdvisoriesGHSA-2vcf-qxv3-2mgw 5.2

Craft CMS has a theoretical bypass for CVE-2025-23209

Pre-requisites:

With those two pieces in place, you could create a specific, malicious request to the /updater/restore-db endpoint to execute CLI commands remotely.

Fixed in https://github.com/craftcms/cms/commit/a19d46be78a9ca1ea474012a10e97bed0d787f57


Reported by Marco O. (segfault)

Record
GHSA-2vcf-qxv3-2mgw
CVSS 4.0
5.2 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-94
Updated
2026-11-02
NVD 5.2

Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.

Record
CVE-2025-54417
CVSS 4.0
5.2 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV 5.2

Craft contains a theoretical bypass for CVE-2025-23209

Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.

Record
CVE-2025-54417
CVSS 4.0
5.2 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-94
Updated
2026-11-02
OSVGHSA-2vcf-qxv3-2mgw 5.2

Craft CMS has a theoretical bypass for CVE-2025-23209

Pre-requisites:

With those two pieces in place, you could create a specific, malicious request to the /updater/restore-db endpoint to execute CLI commands remotely.

Fixed in https://github.com/craftcms/cms/commit/a19d46be78a9ca1ea474012a10e97bed0d787f57


Reported by Marco O. (segfault)

Record
GHSA-2vcf-qxv3-2mgw
CVSS 4.0
5.2 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-94
Updated
2026-11-02
OSVCLSA-2026-1774313530 No score

TuxCare security update for craftcms/cms (10 CVEs)

TuxCare rebuilt craftcms/cms to address 10 CVEs. Fixed in 3.9.15-p1+tuxcare.

Record
CLSA-2026-1774313530
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
craftcms/cms
Packagist
4.13.8 up to 4.16.3
4.16.3
craftcms/cms
Packagist
5.5.8 up to 5.8.4
5.8.4
craftcms/cms
TuxCare:Packagist
From an advisory covering 8 CVEs
3.9.15 up to 3.9.15-p1+tuxcare
3.9.15-p1+tuxcare
craftcms/cms
Packagist
4.13.8 up to 4.16.3, plus listed versions
4.13.104.13.94.14.04.14.0.14.14.0.2
Show 34 moreShow less
4.14.14.14.104.14.114.14.11.14.14.124.14.134.14.144.14.154.14.24.14.34.14.44.14.54.14.64.14.74.14.84.14.8.14.14.94.15.04.15.0-beta.14.15.0-beta.24.15.0.14.15.0.24.15.14.15.24.15.34.15.44.15.54.15.64.15.6.14.15.6.24.15.74.16.04.16.14.16.2
4.16.3
craftcms/cms
Packagist
5.5.8 up to 5.8.4, plus listed versions
5.5.105.5.95.6.05.6.0.15.6.0.2
Show 42 moreShow less
5.6.15.6.105.6.10.15.6.10.25.6.115.6.125.6.135.6.145.6.155.6.165.6.175.6.25.6.35.6.45.6.55.6.5.15.6.65.6.75.6.85.6.95.6.9.15.7.05.7.0-beta.15.7.0-beta.25.7.15.7.1.15.7.105.7.115.7.25.7.35.7.45.7.55.7.65.7.75.7.85.7.8.15.7.8.25.7.95.8.05.8.15.8.25.8.3
5.8.4

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-54417 is a medium vulnerability (CVSS 5.2) in Craftcms Cms, published August 8, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in craftcms/cms 4.16.3.

References

MoveEnter Open