CVE-2025-55559
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set...
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
- Record
CVE-2025-55559- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2025-31122
7.5
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
- Record
EUVD-2025-31122- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-49v8-592x-2x5p
7.5
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set...
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
- Record
GHSA-49v8-592x-2x5p- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
7.5
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
- Record
CVE-2025-55559- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-06
OSV
7.5
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
- Record
CVE-2025-55559- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-07
OSVDEBIAN-CVE-2025-55559
7.5
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
- Record
DEBIAN-CVE-2025-55559- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-55559
7.5
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
- Record
UBUNTU-CVE-2025-55559- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVBIT-tensorflow-2025-55559 No score
An issue was discovered TensorFlow v2.18.0. A Denial of Service (DoS) occurs when padding is set to 'valid' in tf.keras.layers.Conv2D.
- Record
BIT-tensorflow-2025-55559- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
tensorflowBitnami |
2.18.0 up to 2.18.1 | 2.18.1 |
tensorflowDebian:14 |
All versions, plus listed versions 1.10.1+dfsg-A11.10.1+dfsg-A22.14.1+dfsg-12.14.1+dfsg-22.14.1+dfsg-32.14.1+dfsg-3.12.3.1-1 |
None known |
tensorflowUbuntu:25.10 |
All versions, plus listed versions 2.14.1+dfsg-3 |
None known |
tensorflowUbuntu:26.10 |
All versions, plus listed versions 2.14.1+dfsg-3build12.14.1+dfsg-3.12.14.1+dfsg-3.1build1 |
None known |
tensorflowUbuntu:26.04:LTS |
All versions, plus listed versions 2.14.1+dfsg-32.14.1+dfsg-3build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | NVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-55559 is a high vulnerability (CVSS 7.5) in Google Tensorflow, published September 25, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.21%, the 11th percentile. Fixed in tensorflow 2.18.1.
References
github.com/tensorflow/tensorflow/issues/84205
gist.github.com/shaoyuyoung/0e7d2a586297ae9c8ed14d8706749efc
nvd.nist.gov/vuln/detail/CVE-2025-55559
github.com/advisories/GHSA-49v8-592x-2x5p
github.com/CVEProject/cvelistV5/tree/main/cves/2025/55xxx/CVE-2025-55559.json
security-tracker.debian.org/tracker/CVE-2025-55559
ubuntu.com/security/CVE-2025-55559
cve.org/CVERecord?id=CVE-2025-55559