CVE-2025-55671
TkEasyGUI Affected by Uncontrolled Search Path Element Issue
Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Passive
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.5
Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.
- Record
CVE-2025-55671- CVSS 4.0
- 8.5 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-427
- Updated
- 2026-11-02
EUVDEUVD-2025-26896
8.5
Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.
- Record
EUVD-2025-26896- CVSS 4.0
- 8.5 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-ph2w-cx28-vhrq
8.5
TkEasyGUI Affected by Uncontrolled Search Path Element Issue
Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.
- Record
GHSA-ph2w-cx28-vhrq- CVSS 4.0
- 8.5 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-427
- Updated
- 2026-11-02
NVD
8.5
Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.
- Record
CVE-2025-55671- CVSS 4.0
- 8.5 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-427
- Updated
- 2026-11-02
OSV
8.5
Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.
- Record
CVE-2025-55671- CVSS 4.0
- 8.5 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-427
- Updated
- 2026-11-02
OSVGHSA-ph2w-cx28-vhrq
8.5
TkEasyGUI Affected by Uncontrolled Search Path Element Issue
Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.
- Record
GHSA-ph2w-cx28-vhrq- CVSS 4.0
- 8.5 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-427
- Updated
- 2026-11-02
OSVPYSEC-2026-1968
8.5
TkEasyGUI Affected by Uncontrolled Search Path Element Issue
Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.
- Record
PYSEC-2026-1968- CVSS 4.0
- 8.5 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
tkeasyguiPyPI |
before 1.0.22 | 1.0.22 |
tkeasyguiPyPI |
before 1.0.22, plus listed versions 0.1.00.1.10.1.20.1.30.1.4 Show 45 moreShow less0.1.60.2.10.2.160.2.190.2.20.2.200.2.240.2.270.2.280.2.290.2.30.2.300.2.310.2.350.2.380.2.40.2.430.2.440.2.450.2.460.2.470.2.480.2.490.2.550.2.570.2.630.2.670.2.680.2.690.2.710.2.720.2.730.2.740.2.750.2.760.2.771.0.101.0.111.0.121.0.131.0.141.0.161.0.171.0.181.0.2 |
1.0.22 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-55671 is a high vulnerability (CVSS 8.5) in Kujirahand Tkeasygui, published September 5, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.16%, the 5th percentile. Fixed in tkeasygui 1.0.22.
References
github.com/kujirahand/tkeasygui-python/releases/tag/v1.0.22
jvn.jp/en/jp/JVN48739895
nvd.nist.gov/vuln/detail/CVE-2025-55671
github.com/advisories/GHSA-ph2w-cx28-vhrq
github.com/CVEProject/cvelistV5/tree/main/cves/2025/55xxx/CVE-2025-55671.json
github.com/kujirahand/tkeasygui-python
pypi.org/project/tkeasygui
Left out here: 9 versions. The JSON record has them.